abylonsoft: Willkommen

Willkommen / Homepage

Aktuellere Version dieser Software erhältlich?
Prüfen Sie zuerst, ob mittlerweile eine verbesserte oder neuere Softwareversion (aktuell Version 6.0) veröffentlicht wurde. Schauen Sie einfach bei uns auf der Hompage www.abylonsoft.de vorbei!

Willkommen
Vielen Dank, dass Sie sich für das Produkt abylon CRYPTDRIVE von abylonsoft entschieden haben.

Mit dem abylon CRYPTDRIVE von abylonsoft können Sie virtuelle Laufwerke erstellen, auf denen Ihre Daten automatisch nach dem Blowfishverfahren (448 Bit) verschlüsselt gespeichert werden.

>> Beschreibung abylon CRYPTDRIVE

>> Erste Schritte

>> Alle Dialoge

Systemvoraussetzungen:

  • Prozessor: Pentium
  • Arbeitsspeicher: 64 MByte RAM
  • Freier Festplattenspeicher ca. 12 MByte
  • Betriebssystem Windows NT4, XP, 2000 oder 2003
  • optional Chipkartenleser und Zertifikatschipkarte oder USB-Token

Weitere Software von abylonsoft:

abylon LOGON ist eine einfache und flexible Möglichkeit der Anmeldung mit einer Chipkarte an Ihren Computer (Nur für die Betriebssysteme Windows NT, 2000 und XP).

Mit dem abylon SHREDDER können Sie Dateien und Internetspuren (nur Internet Explorer) sicher löschen, ohne dass eine softwaremäßige Rekonstruktion der Daten möglich ist.

Der Funktionsumfang der einzelnen Programmversionen ist im Internet (www.abylonsoft.de) aufgeführt. Außerdem beschreiben wir im Internet (www.abylonsoft.de) weitere Tipps und klären die am häufigsten gestellten Fragen (FAQs).

Zum Schluss wünscht Ihnen das abylonsoft - Team viel Erfolg beim sicheren Arbeiten mit abylon CRYPTDRIVE.

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 17.09.2002 your Webmaster!

Last Update / Stand 28.03.2006


abylonsoft: abylon SUPPORT UND BESTELLUNG

Beschreibung abylon SUPPORT UND BESTELLUNG
Zur Kontaktaufnahme (Feedback) und Registrierung (Bestellung des Lizenzschlüssels oder eines Angebotes) bietet abylonsoft diesen Dialog an, mit dem Sie nach Eingabe aller erforderlichen Daten eine entsprechendes Textdokument (RTF-Format) oder Email erstellen können.

  • Kontaktinformationen
  • Registrierung / Angebot
  • Programmbewertung

Kontaktinformationen

1. Info

Informationen zu diesem Dialog.

2. Seitenauswahl

Wechseln Sie über diese Schalter zwischen den Seiten 'Kontaktinformationen', 'Registrierung / Angebot' und 'Programmbewertung'.

3. Kontaktinformationen

Damit wir mit Ihnen in Kontakt treten können, müssen Sie zwingend Ihren 'Vornamen', 'Nachnamen' und 'Email-Adresse' angeben. Die Angabe Ihrer kompletten Adresse ist nur für die Bearbeitung einer 'Bestellung' oder 'Angebotsanforderung' erforderlich.
HINWEIS: Ihre Daten werden von abylonsoft streng vertraulich behandelt und nicht weiter gegeben!

4. Auswahl Selektieren Sie hier, ob Sie uns ein Feedback (z. B. Frage, Anregung, Kritik) zuschicken oder eine Bestellung bzw. Angebotsaufforderung aufgeben möchten.

Bestellung (Registrierung: Online oder per Bestelldialog / Email):

  • Rechung (Firmenkunden ab einem Rechnungsbetrag von ca. 200 €): Bei direkter Registrierung (Bestellung) schicken wir Ihnen die gewünschte Anzahl an Lizenzschlüsseln für die Freischaltung unserer Software zu. Nach Erhalt der Rechung überweisen Sie den Registrierungsbetrag auf das angegebene Firmenkonto.

  • Privatpersonen: Bei Privatpersonen müssen wir auf Vorkasse bestehen! Hierzu übermitteln wir Ihnen zuerst ein Angebot mit unserem Firmenkonto. Nach Eingang des kompletten Lizenzpreises wird Ihnen der Lizenzschlüssel zum Freischalten der Software übermittelt.

  • Onlinebestellung (Firmen- und Privatkunden): Alternativ bieten wir Ihnen eine unkomplizierte Registrierung über unseren Partner ShareIt an. ShareIt wickelt dabei die Registrierung Online (SSL), per Email, Telefon, Fax oder Brief ab. Als Zahlungsmittel akzeptiert ShareIt alle großen Kreditkarten (Visa, Eurocard / Mastercard, American Express, Diners Club, Switch), Schecks, Überweisungen und Barzahlung (http://www.abylonsoft.de/registration.htm).

Angebotsanforderung:
Alternativ können wir Ihnen zuerst ein Angebot für die angegebene Anzahl der Lizenzen erstellen (Aktuelle Preise finden Sie immer auf unserer Homepage).

Hilfe zur Freischaltung: siehe Registrierungsdialog

5. | Frage / Anregung / Kritik | Textfeld für die Eingabe Ihrer Frage, Anregung oder Kritik.
6. | Newsletter (max. 3x im Jahr) | Bei Aktivierung senden wir Ihnen in unregelmäßigen Abständen eine Email mit Neuigkeiten rund um abylonsoft und unseren Programmen.
7. | Per Post oder Fax senden | Es wird ein Text-Dokument (RTF-Format) mit Ihren Angaben generiert und direkt geöffnet (z. B. mit MS Word - siehe unten). Sie brauchen dieses Dokument nur noch ausdrucken, unterschreiben und an uns per Post oder Fax schicken.
8. | Als Email senden | Es wird eine Email mit Ihren Angaben generiert und an Ihr Email-Programm weitergeleitet. Sie brauchen diese Email nur noch an uns zu senden.

Registrierung / Angebot

1. | Seitenauswahl | Wechseln Sie über diese Schalter zwischen den Seiten 'Kontaktinformationen', 'Registrierung / Angebot' und 'Programmbewertung'.
2. | Anzahl der Lizenzen | Geben Sie in diesem Feld an, wie viele Lizenzen unserer Software Sie benötigen. HINWEIS Für die benötigte Anzahl beachten Sie bitte unsere Lizenzvereinbarungen und AGB's oder setzen sich direkt mit uns in Verbindung!
3. | Software-CD | Auswahl, ob Sie neben den Lizenzschlüsseln auch eine Software-CD wünschen. HINWEIS Neben den Kosten für die CD fallen hierbei Versandgebühren an!
4. | Links | Besuchen Sie die entsprechenden Seiten auf unserer Homepage.

Programmbewertung

1. | Seitenauswahl | Wechseln Sie über diese Schalter zwischen den Seiten 'Kontaktinformationen', 'Registrierung / Angebot' und 'Programmbewertung'.
2. | Programmbewertung | Die Beantwortung dieser Fragen ist nicht zwingend, hilft uns jedoch unser Programm noch besser zu gestalten. Ein kurzer Kommentar im Feld 'Frage / Anregung / Kritik' unterstützt uns bei der Weiterentwicklung unserer Software.
3. | Allgemeine Umfrage | Die Beantwortung dieser Fragen ist nicht zwingend, hilft uns jedoch unser Programm noch besser zu gestalten. Ein kurzer Kommentar im Feld 'Frage / Anregung / Kritik' unterstützt uns bei der Weiterentwicklung unserer Software.

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 16.09.2002 your Webmaster!


abylonsoft: Registration

Registration / Homepage
Allgemein:
Das Herunterladen und die Installation der hier bereitgestellten Software erfolgen auf eigene Gefahr. abylonsoft - Dr. Thomas Klabunde GbR übernimmt keine Gewährleistung oder Haftung für etwaige Schäden, die durch die Installation und / oder Gebrauch entstehen können. Die Nutzer verzichten auf jedwede Ansprüche gegen abylonsoft - Dr. Thomas Klabunde GbR oder Drittanbieter die sich aus diesem Vorgang ergeben können. Mit dem Herunterladen und / oder Kauf der Software erkennen die Nutzer diese Nutzungsbedingungen, unsere AGB's und Lizenz an.

Des weiteren verweisen wir auf unseren Disclaimer...

Registrierung für Schüler, Studenten und öffentliche Einrichtungen:
Für Schüler, Studenten und öffentliche Einrichtungen bietet abylonsoft reduzierte Preise an. Bitte setzen Sie sich diesbezüglich mit uns in Verbindung (siehe Impressum). Wir erstellen Ihnen ein entsprechendes Angebot.

Registrierung für abylon CRYPTDRIVE:

Registrierungsmöglichkeiten (Online oder per Bestelldialog / Email):

  • Rechung (Firmenkunden): Bei direkter Registrierung (Bestellung) schicken wir Ihnen die gewünschte Anzahl an Lizenzschlüsseln für die Freischaltung unserer Software zu. Nach Erhalt der Rechung überweisen Sie den Registrierungsbetrag auf das angegebene Firmenkonto.

  • Privatpersonen: Bei Privatpersonen müssen wir auf Vorkasse bestehen! Hierzu übermitteln wir Ihnen zuerst ein Angebot mit unserem Firmenkonto. Nach Eingang des kompletten Lizenzpreises wird Ihnen direkt der Lizenzschlüssel zum Freischalten der Software übermittelt.

  • Onlinebestellung (Firmen- und Privatkunden): Alternativ bieten wir Ihnen eine Registrierung über ShareIt an. ShareIt wickelt dabei die Registrierung Online (SSL), per Email, Telefon, Fax oder Brief ab. Als Zahlungsmittel akzeptiert ShareIt alle großen Kreditkarten (Visa, Eurocard / Mastercard, American Express, Diners Club, Switch), Schecks, Überweisungen und Barzahlung (Aktuelle Preise und Onlineregistrierung: http://www.abylonsoft.de/registration.htm).
Der Registrierungsdialog:
 Dieses Fenster erscheint nach einigen Operationen, um Sie daran zu erinnern, dass es sich bei bei dieser Software um ein Sharewareprogramm handelt. Aus diesem Grund registrieren Sie bitte unsere Software nach spätestens 30 Tagen oder deinstallieren Sie es. Nach 30 Tagen bleibt der Funktionsumfang erhalten, so dass Sie auch dann noch Ihre verschlüsselten Daten wieder entschlüsseln können. Im Internet unter http://www.abylonsoft.de/registration.htm erhalten Sie weitere Informationen zur Registrierung.

Wenn Sie schließlich den Registrierungsschlüssel erhalten haben, so rufen Sie diesen Registrierungsdialog auf und tragen exakt Ihren Namen in Feld 1 und den Registrierungsschlüssel in Feld 2 ein. Jetzt müssen Sie nur noch das Button 'Jetzt Registrieren' klicken und der Eintrag 'nicht registriert' verschwindet aus den Kopfzeilen und alle Beschränkungen werden aufgehoben.

Vielen Dank für Ihr Vertrauen und in Zukunft ein sicheres Arbeiten wünscht Ihnen Ihr abylonsoft - Team!


abylonsoft: About abylonsoft

About abylonsoft / Homepage
About:
abylonsoft - Dr. Thomas Klabunde GbR ist eine junge Technologiefirma, mit der Kernkompetenz IT-Sicherheit. Wir beraten, helfen und unterstützen Sie in allen Belangen rund um den Schutz Ihrer Daten und Privatsphäre. Unsere Sicherheitslösungen und -Techniken sind sowohl im privaten als auch im geschäftlichen Bereich einsetzbar und sind mittlerweile neben unserer eigenen Software in einer Reihe von weiteren Produkten integriert. Dabei haben wir uns als hochmotiviertes Team zur Aufgabe gemacht, Qualität und Zuverlässigkeit in den Vordergrund zu stellen.
Unsere Produkte arbeiten alle nach genormten und industriell anerkannten Standards wie z. B. PKCS (RSA) zum asymmetrischen Verschlüsseln und Signieren von Daten. Dabei sind diese Programme für die Datenspeicherung genauso gut geeignet, wie zur Datenübertragung. Aus Gründen der Kostenersparnis seitens des Kunden legen wir besonderen Wert auf höchstmögliche Performance, Stabilität und Bedienerfreundlichkeit der Software. Dies spart dem Kunden langwierige und aufwendige Mitarbeiterschulungen und bietet trotzdem einen zuverlässigen Schutz bei sehr geringem Preis.

Impressum / Kontakt:

abylonsoft - Dr. Thomas Klabunde GbR
Amselweg 18
D - 55442 Stromberg
Deutschland / Germany

Email: mail@abylonsoft.de
Tel: +49 - (0)6724 - 60 2759 - 0
Fax: +49 - (0)6724 - 60 2759 - 1

Autor:

Dr. Thomas Klabunde
Pascal Kreschmann
Dipl. Ing. Uwe Velten

Thanks to:
Dipl. Ing. Daniel Kurz (Test)
Dr. Lorenzo Mauricio Mejias Llanos (Übersetzung)
Bernd Schlösser (Beratung)

Copyright / Warranty:

apm, abylonsoft, abylon protection manager (apm), abylon Reader, abylon Basic, abylon Enterprise, apm - Logon, abylon LOGON, apm - Partition Drive, abylon CRYPTDRIVE, apm - Data Drive, abylon SHAREDDRIVE, apm - Schredder, apm - Wipe, apm - Wipefile, abylon SHREDDER, apm - Tresor, apm - Safe, abylon KEYSAFE, apm - Outlook AddIn, apm - SME Email, abylon CRYPTMAIL, apm - Zertifikatsmanager, abylon CERTMANAGER, apm - LDAP, abylon LDAP, apm - Small PKI, abylon SMALL PKI, abylon FILE PKI, abylon DATEI PKI, apm - ZIP Manager, abylon CRYPTZIP, apm - Admin, abylon ADMIN, abylon EINFÜGEN, abylon PASTE, abylon SYMM CRYPT, abylon HYBRID CRYPT, abylon SUCHEN, abylon FIND, abylon CLIENT SECURITY und deren Module

Copyright © 2001-2006 abylonsoft - Dr. Thomas Klabunde GbR, Amselweg 18, 55442 Stromberg, Deutschland.
Alle Rechte vorbehalten.

Alle im Programm, der Hilfe oder Dokumentation angegebenen Warenzeichen sind Eigentum der jeweiligen Besitzer.

  • Inc. Microsoft is a registered trademark and Windows and the Microsoft logo are trademarks of Microsoft Corporation
  • IBM and PC are trademarks of International Business Machines Corporation
  • iMac is a registered trademark of Apple Computer Inc
  • WinCrypt is a registered trademark (german) of ITecon
  • Other names and products are maybe trademarks of other unknown Inc.


abylonsoft: Willkommen

Erste Schritte (Technik) / Homepage
Erste Schritte (Technik)

>> Einrichten und Verwenden des abylon CRYPTDRIVE

>> Einstellungen

>> Erstellen eines Zertifikates

>> Installation

>> Installation eines Zertifikates

>> Verwenden der Small PKI

>> Zugriff auf einen LDAP-Server


abylonsoft: abylon CRYPTDRIVE Technik

Einrichten und Verwenden von abylon CRYPTDRIVE
ACHTUNG: Das virtuelle Laufwerk abylon CRYPTDRIVE ist nur für Windows NT / 2000 und XP konzipiert. Alternativ können Sie das abylon SHAREDDRIVE (Datenlaufwerk) verwenden, welches auch die Betriebsysteme Windows 9x und ME unterstützt.

1. Einstellungsdialog Öffnen
Öffnen Sie im Einstellungsdialog die Seite CryptDrive.

2. Verschlüsselungseinstellungen
Wählen Sie unter Punkt 11 den gewünschten Verschlüsselungsalgorithmus (Default Encryption ALG) aus. Die Zugriffsberechtigung beim SYMM-System (für Privatanwender empfohlen) erfolgt mittels Passwort (oder EC-KV-Karte) und beim HYBRID-System (für Firmen) durch X.509-Zertifikate.

3. Neu anlegen
Klicken Sie auf den Schalter 6 'Neu anlegen'.

4. Laufwerkseigenschaften
In dem sich öffnenden Dialog können Sie nun die Eigenschaften des Lauswerks festgelegen, wie Name, Größe, Laufwerksbuchstaben, Speicherort und Partials (Teile). Der Speicherort kann sich auch auf einem Netzwerkserver befinden und muss hier als UNC-Pfad eingetragen werden. Die Imagedatei wird in diesem Fall verschlüsselt auf den Server abgelegt und beispielsweise von automatischen Backupsystemen gesichert. Ein Klick auf den Button 'Neu anlegen' schließt den Dialog und legt das Laufwerk an.

INFO: In der Testphase dieser Software ist die Größe des Laufwerks auf 100 MB begrenzt und es kann maximal nur ein Laufwerk angelegt werden. In der registrierten Version sind bis zu 10 Laufwerke mit einer fast unbegrenzten Kapazität (bis 64 GByte getestet) je Laufwerk denkbar.

5. Laufwerksliste
Nun wird Ihr neues Laufwerk in der Liste 4 angezeigt. Bei Laufwerken auf HYBRID-Basis wird in der unteren Liste 15 die berechtigten Zertifikate aufgeführt. Dies entfällt bei SYMM-System Laufwerken.

INFO: Bei zertifikatsbasierten Laufwerken (HYBRID-System) können mit dem Schalter 12 'Hinzufügen' weitere Zertifikate dem abylon CRYPTDRIVE zugewiesen werden.

6. Öffnen
Mit dem Schalter 3 'Öffnen' wird das Laufwerk geöffnet (gemountet) und im Datei Explorer angezeigt.

INFO: Beim ersten Öffnen des Laufwerkes wird dieses formatiert. Dies kann einige Zeit (mehrere Minuten) in Anspruch nehmen.

7a. Passwortes (SYMM-System)
Beim passwortbasierten abylon CRYPTDRIVE (SYMM-System) müssen Sie nun das Passwort zweimalig eingeben oder eine EC-/KV-Karte einlegen.

7b. Passworteingabe (HYBRID-System)
Bei zertifikatsbasierten abylon CRYPTDRIVE (HYBRID-System) müssen Sie Ihre Zertifikatschipkarte oder den USB-Token einlegen und das entsprechende Passwort eingeben. Dies ist auch notwendig, wenn Sie ein Softwarezertifikat mit hoher Sicherheit verwenden.
 HINWEIS Das Eingabefenster für das Passwort kann je nach Anbieter unterschiedlich aussehen!

8. Arbeiten
Nun öffnet sich direkt der Datei Explorer, in dem Sie wie gewohnt Dateien kopieren, anlegen und löschen können. Ebenfalls möglich ist die Laufwerksfreigabe im Netzwerk oder die Festlegung weiterer NT Benutzerrechte (sofern es sich um eine NTFS-Partition handelt).

9. Schließen
Zum Schließen des Laufwerks müssen Sie nur im Einstellungsdialog das Button 'Schließen' klicken.

INFO: Das virtuelle Laufwerk wird spätestens beim Runterfahren des Computers geschlossen.

TIPP: Im abylon CRYPTDRIVE Dialog können Sie sich ganz einfach Links zum Öffnen und Schließen des Laufwerkes auf dem Desktop erstellen lassen. Dazu selektieren Sie das Laufwerk und drücken die rechte Maustaste. Hier wird nur der Punkt 'Verknüpfung auf dem Desktop' angeklickt.
Auch das Öffnen (Mounten) eines Laufwerkes direkt nach dem Hochfahren des Computers ist möglich, indem Sie diesen Link einfach in den Autostart (Start->Programme->Autostart) kopieren.


abylonsoft: Erstellung und Installation eines Zertifikates

Notwendigkeit eines Zertifikates
Die asymmetrische Verschlüsselung (HYBRID-System) beruht auf der Verwendung von X.509 Zertifikaten mit einem öffentlichen (Public Key) und einem privaten Schlüssel (Private Key). Auf diesem System baut die Software von abylonsoft auf.

Erstellung eines Zertifikates
ACHTUNG: Bei den durch diese Software erstellten Zertifikaten handelt es sich um selbstsignierte Zertifikate. Diese sind damit nicht authentisch, das heißt sie sind nicht durch eine öffentliche Zertifizierungsstelle bestätigt und sollten nur im privaten Umfeld eingesetzt werden. Für ein authentisches Zertifikat wenden Sie sich bitte an ein öffentliche Zertifizierungsstelle, wie z. B. TC Trustcenter oder D-Trust.

1. Ein selbstsigniertes Zertifikat können Sie mit wenigen Klicks über das Modul abylon SELFCERT erstellen. Klicken Sie einfach auf das folgende Icon.

2. Danach müssen Sie noch bestätigen, dass Sie die erstellten selbstsignierten Zertifikate nicht missbrauchen und nur privat nutzen.

3. Im Dialog abylon SELFCERT geben Sie nun Ihren Namen, Ihre Email-Adresse, die Schlüssellänge und die Laufzeit ein.

4. Das Zertifikat können Sie vor einer unberechtigten Installation durch ein Passwort schützen. Dieses Passwort hat nichts mit dem Kennwort zu tun, welches Sie später für Ihre Datenverschlüsselung und Signatur verwenden. Dieses wird am Ende der Zertifikatsinstallation festgelegt.

5. Das erstellte Zertifikat wird in Form einer PFX-Datei gespeichert. Sichern Sie diese Datei vor unberechtigten Zugriffen und legen Sie sich unbedingt eine Sicherheitskopie auf Diskette an.
ACHTUNG: Bei einer Neuinstallation Ihres Rechners, einem harten Systemcrash oder einem versehentlichen Löschen des Zertifikats ist eine Entschlüsselung Ihrer Daten nur mit diesem Originalzertifikat möglich. Das erneute Erstellen eines gleichnamigen Zertifikates hilft Ihnen in diesem Fall nicht weiter, weil der entsprechende Schlüssel durch interne Zufallsgeneratoren immer wieder neu generiert wird und sich niemals wiederholt.

6. Nun können Sie das erstellte Zertifikat direkt in Ihre Zertifikatsdatenbank importieren. Dazu sehen Sie sich die Anleitung zur Installation eines Zertifikates an.

Installation eines Zertifikates
1. Zur Installation eines Zertifikates müssen Sie nur ein doppelt auf eine Zertifikatsdatei klicken. Diese haben die Dateiendung PFX oder P12.

Wenn Sie sich vorher mit dieser Software ein selbstsigniertes Zertifikat erstellt haben, den letzten Dialog mit 'Ja' bestätigt haben, dann startet die Installationsroutine automatisch.

2. Auf der 2. Seite des Installationsassistenten wird noch einmal das zu installierende Zertifikat angezeigt.

3. Auf der 3. Seite müssen Sie das Passwort eingeben, mit dem das Zertifikat geschützt ist. Sinnvoll ist es auch, die beiden Punkte 'Hohe Sicherheit' und 'Exportierbarkeit' zu aktivieren. Dadurch können Sie am Ende der Installation den Zugriff auf Ihr Zertifikat mit einem Passwort schützen und später auch wieder mit privaten Schlüssel exportieren.

4. Auf der 4. Seite müssen Sie die Zertifikatsdatenbank auswählen, in dem das Zertifikat gespeichert werden soll. Dazu wird der Punkt 'Alle Zertifikate in folgendem Speicher speichern' ausgewählt. Über das Button 'Durchsuchen...' öffnet sich der Dialog zum Auswählen des Zertifikatsspeichers. Hier ist der erste Punkt 'Eigene Zertifikate' zu wählen. Nach dem Bestätigen mit dem Button 'OK' schließt sich der Dialog wieder und in dem Feld Zertifikatsspeicher steht nun die Zertifikatsdatenbank 'Eigene Zertifikate'.

5. Auf der letzten Seite werden noch einmal alle relevanten Daten angezeigt. Den Installationsassistenten schließen Sie mit dem Button 'Fertig stellen'.

6. Zum Schluss muss noch die Sicherheitsstufe festgelegt werden. Klicken Sie dazu auf das Button 'Sicherheitsstufe..'.

7. Hier sollten Sie die Stufe 'Hoch' wählen, damit Sie bei jeder Signier- oder Entschlüsselungsaktion nach dem Passwort gefragt werden.

8. Danach müssen Sie noch ein Passwort eingeben und das Button 'Fertig stellen'' klicken.

9. Nun müssen Sie nur noch den Dialog (siehe Punkt 5) mit 'OK' bestätigen. Damit ist die Installation des Zertifikates abgeschlossen und Sie finden Ihr Zertifikat im abylon CERTMANAGER in der Datenbank 'My (Private Zertifikate)'. Über das Button 'Aktivieren' können Sie dieses Zertifikat als Ihr 'Eigenes Zertifikat' (gelb hinterlegter Schlüssel) festlegen. In Zukunft werden alle Signier- und Verschlüsselungsoperationen mit Hilfe dieses Zertifikates durchgeführt.


abylonsoft: abylon INSTALLATION

Installation
 ACHTUNG: Vor der Installation sollten Sie alle alten Versionen dieser Software deaktivieren und deinstallieren. Dazu gehen Sie im Startmenu in das entsprechende Verzeichnis und wählen den Punkt 'deinstallieren' aus. Alternativ kann das Programm auch über den Eintrag 'Software' in der 'Systemsteuerung' entfernt werden.

1. Alle Softwareprodukte von abylonsoft werden mit einem Installationsprogramm ausgeliefert. Dieses führt Sie Schritt für Schritt durch die Installation und nimmt alle wichtigen Einstellungen auf Ihrem System vor. Schließen Sie alle anderen Programme und starten einfach die entsprechende Setupdatei durch Doppelklick.

2. Wählen Sie die Programmsprache (zur Zeit Deutsch, Englisch und Spanisch (Beta))!

3. Im Setup müssen Sie zuerst die Lizenzvereinbarung akzeptieren.
Weiter geht es mit der Angabe des Verzeichnisses, wo das Programm auf der Festplatte gespeichert wird und wie der Ordner im Startmenü heißen soll. Auf der letzten Seite können Sie die Software direkt starten.

4. Wichtig ist, dass Sie sich erst mit dem Programm vertraut machen und z. B. unwichtige Daten (Testdateien) verschlüsseln, bevor Sie Ihre wichtigen Daten verschlüsseln. Bei einigen kostenlosen Zertifikatsausstellern werden falsche bzw. minderwertige Zertifikate erzeugt, mit denen Sie wegen eines Fehlers die Daten nur verschlüsseln und nicht mehr entschlüsseln können.
Spätestens nach Ablauf der Testphase von 30 Tagen müssen Sie die Lizenzgebühr für die installierte Version bezahlen oder das Programm deinstallieren. Bedenken Sie bitte, dass eine Weiterentwicklung unsererseits nur durch faires Verhalten Ihrerseits möglich ist und jeder eine entsprechenden Vergütung für seine Arbeit erhalten möchte.

5. Jetzt werden Sie noch gefragt, ob Sie noch Programmverknüpfungen (Symbole) auf dem Desktop zum schnelleren Zugriff ablegen möchten und ZIP-Dateien mit abylon CRYPTZIP verknüpfen wollen (HINWEIS Entfällt).

6. Die Software von abylonsoft kann in zwei Variationen betrieben werden, wobei unterschiedliche Voreinstellungen vorgenommen werden :

  • Privatanwender (passwortbasiert): Hierbei wird als Voreinstellung das SYMM-System verwendet, wobei die Verschlüsselung und Zugangsberechtigungen durch die Eingabe von Passwörtern (oder EC-/KV-Karte) erfolgt. Als symmetrische Verschlüsselungsalgorithmen werden zur Zeit Blowfish (448 Bit) und AES (256 Bit) angeboten und ist vor allem für kleinere Unternehmen und Privatanwender geeignet.
  • Unternehmen (X.509 zertifikatsbasiert): Hierbei wird als Voreinstellung das HYBRID-System verwendet, wobei die Verschlüsselung und Zugangsberechtigungen mit Hilfe von X.509 Zertifikaten erfolgt. Die asymmetrische Verschlüsselung basiert auf dem PKCS-Standard von RSA und ist für mittlere und größere Unternehmen mit größerem administrativen Aufwand geeignet. Sofern das interne symmetrische Verschlüsselungsverfahren nicht durch das Betriebssystem vorgegeben ist, wird Blowfish (448 Bit) und AES (256 Bit) angeboten.

HINWEIS Sie sollten nur den Unternehmens-Modus wählen, wenn Sie sich mit der Technik der asymmetrischen Verschlüsselung auskennen und möglichst schon im Besitz von Zertifikaten sind. Ein nachträgliche Änderung der Einstellungen auf das HYBRID-System (Unternehmen) ist jederzeit möglich.

7. Um alle Änderungen in Ihrem System zu übernehmen und alle PlugIns zu aktivieren, muss der Rechner neu gestartet werden.

8. Damit diese Software im Unternehmensmodus arbeiten kann, muss ein Zertifikat auf Ihrem Rechner installiert sein. Wenn Sie nicht wissen, ob dies schon der Fall ist, so öffnen Sie einfach den abylon CERTMANAGER. Falls schon ein Zertifikat vorhanden ist, so selektiert der abylon CERTMANAGER dieses automatisch und Sie müssen nur noch das Button 'Übernehmen' klicken. Falls jedoch kein Zertifikat installiert ist, so wird der Dialog zum Erstellen eines selbstsignierten Zertifikates geöffnet (abylon SELFCERT).

Ein Anleitung zur Installation des Zertifikates finden Sie auf der Hilfeseite zur Installation eines Zertifikates.

Deinstallation:
Zum Entfernen der Software von Ihrem Rechner müssen Sie im Startmenü - Ordner den Punkt 'Programm entfernen' aufrufen. Alternativ ist es auch möglich die Software unter Start -> Einstellungen -> Systemsteuerung -> Software -> Button 'Ändern/Entfernen' zu deinstallieren.

Deaktivierung:
Im Gegensatz zur Deinstallation kann die Software auch kurzfristig deaktiviert werden. Dazu öffnen Sie einfach im Einstellungsdialog die Seite 'ADMINISTRATION' und drücken den Schalter 'Module aktivieren / deaktivieren'. Über den gleichen Schalter lässt sich das Programm wieder aktiveren.

Siehe auch
>> Hilfeseite zur Installation eines Zertifikates
>> Hilfeseite zur Registrierung


abylonsoft: abylon KEYEXCHANGE Technik

Austausch des öffentlichen Schlüssels (Public Key)
Die Basis der asymmetrischen Verschlüsselung (HYBRID-System) von Daten für Dritte ist der öffentliche Schlüssel (Public Key) dieser Person. Wenn Sie Daten für 'HANS' verschlüsseln wollen, dann müssen Sie erst einmal in den Besitz seines öffentlichen Schlüssels von 'HANS' kommen. Diese Software bietet dazu eine Reihe von Möglichkeiten an. Diese sollen Ihnen hier vorgestellt werden.

A. Zugriff auf einen LDAP-Servers

B. Verwendung der abylon SMALL PKI

A. Zugriff auf einen LDAP-Servers
Firmen und Trustcenter bieten eine so genannte Public Key Infrastructure PKI an, über welche öffentlichen Schlüssel (Public Keys) online abgerufen werden können. Dadurch kann direkt für eine Person verschlüsselt werden, ohne vorher den öffentlichen Schlüssels auszutauschen. Die Version abylon ENTERPRISE bietet Möglichkeit auf diese Server zuzugreifen und nach Zertifikaten zu suchen.

1. Beim Bilden eine SME-Datei öffnet sich der abylon CERTMANAGER zum Selektieren des öffentlichen Schlüssels (Public Keys). Nun können Sie den Dialog zum Durchsuchen eines LDAP-Servers öffnen.

2. In diesem Dialog sind einige Angaben zum LDAP-Server und der Suchbasis einzugeben. Alternativ können Sie einen der vorgegebenen LDAP-Server (z. B. TC Trustcenter oder D-Trust) verwenden.

3. Geben Sie die den zu suchenden Namen oder die Email-Adresse an und drücken das Button 'Suchen'.

INFO: Es können Wildcards (Sternchen *) verwendet werden, jedoch bricht der LDAP-Server bei einem Überschreiten einer maximalen Anzahl an gefundenen Einträgen mit einer Fehlermeldung ab. In diesem Fall müssen Sie das Suchkriterium weiter eingrenzen.

4. Im oberen Feld werden alle Suchergebnisse angezeigt. Die selektierten Einträge werden durch das Button 'Übernehmen' in den abylon CERTMANAGER übertragen.

5. Die selektierten Einträge finden Sie nun in der Zertifikatsdatenbank 'LDAP (Onlinezertifikate)'. Diesen können sie nun zum Verschlüsseln verwenden. Der öffentliche Schlüssel bleibt Ihnen für die nächsten Verschlüsselungen erhalten, sodass Sie nicht erneut auf dem LDAP-Server suchen müssen. Sie können auch jederzeit ein LDAP-Zertifikat Offline verfügbar machen, indem Sie dieses von der Datenbank 'LDAP' in die Datenbank 'MY' kopieren.

INFO: Mit öffentlichen Schlüsseln (PKCS#7-Zertifikaten) verschlüsselte Daten können nur von dem Besitzer des privaten Schlüssels (PKCS#12-Zertifikaten) wieder entschlüsselt werden.
B. Verwendung der Small PKI
Die Anbindung an die netzwerkinterne Public Key Infrastruktur (Small PKI) von abylonsoft ermöglicht den zentralen Zugriff auf alle benötigten Zertifikate. Gerade in kleineren und mittleren Netzwerken (bis zu 50 Rechnern) wird der administrative Aufwand deutlich reduziert und macht zudem den kostenintensiven Einsatz von aufwendigen LDAP-Servern überflüssig.

Bei Aktivierung wird im abylon CERTMANAGER zusätzlich der Punkt Small PKI angezeigt, auf dem alle Anwender (auch übers Netzwerk) zugreifen können. Dazu werden die Zertifikate auf dem Server ( Punkt 6) in der Registry unter HKLM gespeichert. (Berechtigungen in der Registry beachten!)

Bei deaktivierter Small PKI wird der Punkt Small PKI aus dem abylon CERTMANAGER entfernt und die Benutzer können nur noch auf die eigene Zertifikatsdatenbank zugreifen.

AUF DEM SERVER

1. Öffnen Sie im Einstellungsdialog die Seite Schlüsselverwaltung - PKI.

2. Aktivieren Sie mit dem dem Button 1 die Small PKI und tragen in Feld 3 die Rechnernamen des Servers ein (hier SP-TOM).

3. Kopieren Sie die Datenbank, die allen Anwendern verfügbar gemacht werden soll in die Liste 7 'Anzuzeigende Zertifikate' (hier 'My').

4. Öffnen Sie den abylon CERTMANAGER und kopieren alle benötigten Zertifikate (z. B. aller Mitarbeiter) in die unter Punkt 3 ausgewählte Datenbank (beispielsweise 'My').
(Schnellanleitung Zertifikat kopieren: 1. Zertifikat auswählen 2. Im Menu der rechten Maustaste den Punkt 'Kopieren' wählen 3. In die Small PKI wechseln 4. Im Anzeigefeld der Zertifikate im Menu den Punkt 'Einfügen' wählen)

AUF DEM CLIENT

1. Führen Sie ebenfalls auf dem Client die Punkte 1. - 3. durch!

2. Nun sind auf dem Client alle auf dem Server eingerichteten Zertifikate verfügbar und können in allen Modulen verwendet werden!

HINWEIS Die eigenen Zertifikate (PKCS#12 -> privater Schlüssel) müssen lokal auf dem Client verfügbar sein! Dazu verwenden Sie am besten einen Zertifikatschipkarte, einen USB-Token oder installieren das Softwarezertifikat direkt auf dem Client. Die Installation des Softwarezertifikates wird automatisch durch die Software gestartet, wenn die PFX-Zertifikatsdatei im Control-Verzeichnis abgelegt wird!

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 24.09.2002 your Webmaster!


abylonsoft: Willkommen

Dialoge / Homepage
Alle Dialoge

>> abylon LDAP

>> abylon CRYPTDRIVE

>> abylon CERTMANAGER

>> abylon CERTCHECK (Revocation List)

>> abylon EINSTELLUNGEN

>> abylon KEYGENERATOR

>> abylon REGISTRIERUNG / ANGEBOT

>> abylon SELFCERT

>> abylon SUPPORT

>> abylon ZUGRIFFSPRÜFUNG


abylonsoft: abylon CERTCHECK (revocation list)

Beschreibung abylon CERTCHECK (revocation list)
 Im Dialog abylon CERTCHECK wird das Ergebnis der Zertifikatsprüfung (Revocation check) angezeigt und übersichtlich dargestellt. Dies kann beispielsweise aus dem abylon CERTMANAGER oder der abylon SIGNATURINFORMATION erfolgen. Für die Sperrlistenprüfung ist eine Onlineverbindung notwendig.

Übersicht abylon CERTCHECK (revocation list)

1. | Information | Anzeige von allgemeinen Informationen.
2. | Zertifikatsprüfung (revocation list) | 1. Zeile: Zertifikatsinhaber 2. Zeile: Speicheroption 3. Zeile: Gültigkeit 4. Zeile: Sperrlistenprüfung (revocation check) HINWEIS Internetverbindung notwendig 5. Zeile: Zusätzliche Schlüsselinformationen 6. Zeile: Zertifikat für Signaturoperation verwendbar? 7. Zeile: Zertifikat für Verschlüsselungsoperation verwendbar?

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 16.09.2002 your Webmaster!

Last Update / Stand 30.03.2006


abylonsoft: abylon CERTMANAGER

HINWEIS Der abylon CERTMANAGER wird nur für das HYBRID-SYSTEM benötigt!
Beschreibung abylon CERTMANAGER
 Der abylon CERTMANAGER ist das zentrale Modul vieler abylonsoft Produkte. Hier können Sie alle Zertifikate zum Verschlüsseln (HYBRID-System) und Signieren verwalten, wobei folgende Funktionen und Operationen unterstützt werden ...

Funktionsumfang:

  • Anzeigen der Windowszertifikatsdatenbanken mit den enthaltenen Zertifikaten
  • Importieren Ihres eigenen PKCS#12-Zertifikates
  • Erstellen eines voll funktionsfähigen, selbstsignierten PKCS#12 Testzertifikates
  • Löschen nicht mehr benötigter Zertifikate
  • Zertifikatsinformationen einsehen (Doppelklick)
  • Datei PKI1) oder Small PKI1) verwenden
  • Zertifikat als CRT-Datei (nur mit öffentlichen Schlüssel) per Email versenden
  • LDAP-Zertifikate1) (nur öffentliche Schlüssel) in Verzeichnisdiensten suchen und lokal verfügbar machen
  • Dem abylon KEYSAFE1) oder den einzelnen verschlüsselten Laufwerken (abylon CRYPTDRIVE1) und abylon SHAREDDRIVE1)) berechtigte Zertifikate zuweisen
  • Backupzertifikate1) festlegen
  • Öffentliche Schlüssel für SME-Dateien selektieren1)
  • Zertifikate kopieren, ausschneiden oder verschieben (per Drag&Drop oder über die rechte Maustaste)
  • Sperrlistenprüfung (Revocation list) einzelner Zertifikate über die rechte Maustaste
  • Basiszertifikat zum Verschlüsseln und Signieren aller Objekte mit dem Button 'Aktivieren' auswählen

1) Je nach verwendeter Software können einzelne Module oder Funktionen entfallen! Weitere Informationen siehe detaillierte Produktbeschreibung oder unseren Produktvergleich im Internet.

Übersicht abylon CERTMANAGER

1. | Statusinfo | Anzeige von Statusinformation zu dem in der Liste 23 ausgewählten Zertifikat.
2. | Importieren | Importieren von Zertifikatsdateien nach PKCS#12 mit den Dateiendungen PFX oder P12.
3. | Erstellen | Öffnet die Oberfläche abylon SELFCERT zum Erstellen von selbstsignierten Testzertifikaten (X.509 / V3) für den privaten Gebrauch.
4. | Löschen | Entfernt das selektierte Zertifikat aus der Liste und aus der Windowsdatenbank. HINWEIS Um Probleme in anderen Anwendungen zu vermeiden sollten nur bekannte Zertifikate gelöscht werden.
5. | Info | Zeigt die Zertifikatsinformationen zum selektierten Zertifikat an.
6. | Senden | Verschickt den öffentlichen Schlüssel (Publik Key - CRT-Datei) des selektierten Zertifikats als Anlage einer Email. HINWEIS Der Empfänger kann mit diesem Zertifikat für Sie Daten verschlüsseln und Ihre digitale Unterschrift prüfen. Eine Entschlüsselung Ihrer Daten oder das Unterschreiben in Ihrem Namen ist mit dem öffentlichen Schlüssel NICHT möglich.
7. | Add LDAP 1) | Öffnet den Dialog zum Abrufen von öffentlichen Zertifikate in einem LDAP-Verzeichnis. Hierzu ist eine Internetverbindung notwendig.
8. | Über | Öffnet einen Informationsdialog mit Ihren Registrierungsdaten.
9. | Ver- und Entschlüsselungs -zertifikat | Auswahl und Anzeige des 'Eigenen Zertifikates' für Ver- und Entschlüsselungsoperationen (nur HYBRID-System!). Bei lokalen Verschlüsselungsoperationen (z. B. im Datei Explorer) werden mit dem hier gewählten Zertifikat die Daten verschlüsselt. Mit Ihrem Privaten Schlüssel sind nur Sie persönlich in der Lage die Daten wieder zu Entschlüsseln. HINWEIS Erstellen Sie sich von Ihrem Zertifikat (PFX-Datei) eine Sicherheitskopie auf einen externen Datenträger, damit Sie bei Problemen oder einer Neuinstallation Ihre Daten wieder entschlüsseln können.
10. | Signaturzertifikat | Auswahl und Anzeige des 'Eigenen Zertifikates' zum Signieren (Digital unterschreiben). HINWEIS Dieses Zertifikat kann identisch mit dem Verschlüsselungszertifikat sein.
11. | Private Schlüssel (PKCS#12 Zertifikate) | Auflistung aller Zertifikatsdatenbanken. Zur ausgewählten Zertifikatsdatenbank werden in Feld 23 alle installierten Zertifikate mit einem privaten Schlüssel (PKCS#12, Private Key) angezeigt. HINWEIS Ihre Zertifikate stehen normalerweise in der Datenbank My (Private Zertifikate).
12. | Öffentliche Schlüssel (PKCS#7 Zertifikate) | Auflistung aller Zertifikatsdatenbanken. Zur ausgewählten Zertifikatsdatenbank werden in Feld 23 alle installierten Zertifikate mit öffentlichen Schlüssels (PKCS#7, Public Key) angezeigt. Hier werden auch alle gespeicherten LDAP-Zertifikate in der Datenbank LDAP (Onlinezertifiakte) angezeigt. 1) HINWEIS: Ihre Zertifikate stehen normalerweise in der Datenbank My (Private Zertifikate) und hier können Sie beispielsweise das Zertifikat des Empfängers auswählen, für den Sie eine Signierten und Verschlüsselten Datei (SME: Secure Message Envelope) erstellen möchten. Nur in der ENTEREPRISE-Version ist es möglich mehrere berechtigte Zertifikate auszuwählen.
13. | abylon Small PKI | Anbindung an die netzwerkinterne Public Key Infrastruktur (PKI) von abylonsoft. HINWEIS In den Einstellungen (Schlüsselverwaltung->PKI) kann ein Rechner ausgewählt werden, auf dem alle benötigten Zertifikate in der Registry gespeichert werden. Hierfür muss die Netzwerkverbindung immer bestehen.
14. | abylon Datei PKI | Anbindung an dateibasierte Public Key Infrastruktur (PKI) von abylonsoft. HINWEIS In den Einstellungen (Schlüsselverwaltung->PKI) kann die STO-Datei ausgewählt werden, in der alle benötigten Zertifikate gespeichert werden. Diese Datei kann auch auf einem Netzwerkrechner liegen.
15. | abylon SHAREDDRIVE 1) | Auflistung aller eingerichteten abylon SHAREDDRIVEs (Lokal und FTP) auf HYBRID-Basis. Zu den entsprechenden Laufwerken werden in Liste 23 die Zertifikate aufgeführt, deren Inhaber auf das entsprechende Datenlaufwerk zuzugreifen können.
16. | abylon CRYPTDRIVE 1) | Auflistung aller eingerichteten abylon CRYPTDRIVEs auf HYBRID-Basis. Zu den entsprechenden Laufwerken werden in Liste 23 die Zertifikate aufgeführt, deren Inhaber auf das entsprechende virtuelle Laufwerk zuzugreifen können.
17. | abylon BACKUP 1) | Auflistung aller Backupzertifikate, die beim Verschlüsseln auf HYBRID-Basis berücksichtigt werden. Vor allem Firmen können hier den öffentlichen Schlüssel eines Administratorzertifikates definieren, mit dem die Daten des Mitarbeiters im Notfall entschlüsselt werden können. INFO Bei Laufwerken abylon CRYPTDRIVE und abylon SHAREDDRIVE oder den abylon KEYSAFE für Passwörter werden die Backupzertifikate nicht berücksichtigt. Wollen Sie dennoch mit dem Backupzertifikat auf die entsprechenden Daten zugreifen können, so muss das Backupzertifikat individuell der entsprechenden Liste der berechtigten Zertifikate hinzugefügt werden.
18. | abylon KEYSAFE 1) | Auflistung aller Zertifikate, die berechtigt sind den abylon KEYSAFE auf HYBRID-Basis zu öffnen.
19. | Onlinezertifikat(e) (LDAP) anzeigen 1) | Bei Aktivierung dieses Punktes werden alle LDAP-Onlinezetifikate angezeigt, die Sie mit dem Dialog abylon LDAP hinzugefügt haben. Dazu ist eine Internetverbindung notwendig. Sie können jederzeit die LDAP-Zertifikate Offline verfügbar machen, indem Sie das entsprechende Zertifikat wählen und beispielsweise in die Datenbank My (Eigene Zertifikate) kopieren.
20. | Alle Datenbanken anzeigen | Bei Aktivierung dieses Punktes werden alle Windows Zertifikatsdatenbanken auf dem Rechner angezeigt. Zur besseren Übersicht können unwichtige Zertifikatsdatenbanken ausgeblendet werden.
21. | Zertifikat(e) in Sperrliste prüfen 1) | Bei Aktivierung dieses Punktes werden die angezeigten Zertifikate überprüft, ob diese sich auf einer Sperrliste befinden. Dieser Vorgang benötigt eine Internetanbindung und kann teilweise einige Zeit in Anspruch nehmen.
22. | Schließen / Selektieren | Mit diesem Schalter schließen Sie den Dialog oder übernehmen die selektierten Zertifikate zum Verschlüsseln (bei Digital Envelope erstellen).
23. | Zertifikatsliste | Zeigt die in der entsprechenden Datenbank gespeicherten Zertifikate an.

1) Je nach verwendeter Software können einzelne Module oder Funktionen entfallen! Weitere Informationen siehe detaillierte Produktbeschreibung oder unseren Produktvergleich im Internet.

Siehe auch
>> Hilfe zur Erstellung eines Zertifikates
>> Hilfe zur Installation eines Zertifikates
>> Technik zum Austausch des öffentlichen Schlüssels
>> Verwendung der SMALL PKI


abylonsoft: abylon CRYPTDRIVE

Nur abylon ENTERPRISE Im Funktionsumfang dieser Version und abylon CRYPTDRIVE Im Funktionsumfang dieser Version
Beschreibung des abylon CRYPTDRIVE (virtuelle Laufwerke - Containerlösung)
Auf dem Computer gespeicherte Dateien können auf vielfältige Weise in die falschen Hände gelangen. Abhilfe schafft nur eine ausreichende Verschlüsselung der Daten. Das abylon CRYPTDRIVE bietet ein einfaches Verfahren zum Erstellen von verschlüsselten Laufwerken, den sogenannte Container. Durch die Verschlüsselung mit dem Blowfish- (448 Bit) oder AES-Algorithmus (256 Bit) sind die auf dem Laufwerk gespeicherten Dateien und Programme vor unbefugtem Zugriff gesichert. Erst wenn das Laufwerk geöffnet wird, ist ein Zugriff über den Datei Explorer möglich, wobei die Ver- und Entschlüsselung automatisch und im Hintergrund erfolgt. Als Geheimnis zum Öffnen des Laufwerkes kann entweder ein Passwort über die Tastatur eingegeben oder alternativ eine Chipkarte, CD oder ein USB-Stick verwendet werden.
Im professionellen Umfeld können auch die Zugriffsberechtigungen über Zertifikate administriert werden. Dabei werden zahlreiche Zertifikatschipkarten oder USB-Token unterstützt.

Funktionsumfang:

  • Verschlüsselung mit dem Blowfish- (448 Bit) oder AES-Algorithmus (256 Bit)
  • Vollkommene Integration als Laufwerk in den MS Datei Explorer
  • Unterstützte Geheimnisse (Schlüssel) für die Zugriffsberechtigung:
    • SYMM-System
      • Passwort über die Tastatur
      • Chipkarten (z. B. EC- oder KV-Karten)
      • NEU Externe Speichermedien (z. B. USB-Sticks)
      • NEU CDs/DVDs
      • NEU Kombination von Passwort und Token
    • HYBRID-System
      • X.509 Softwarezertifikate
      • Zertifikate auf Chipkarten oder USB-Token
  • Größe fast unbegrenzt (bis zu 128 GB getestet und freigegeben)
  • Die verschlüsselten Image-Dateien können in bis zu 100 Teile (Partitials) aufgeteilt werden (NEU Unterstützung von Partitials größer 4 GB)
  • Administrierbare Tastenkombination
  • Der Speicherort der Image-Dateien kann auf dem lokalen Rechner oder einem Netzwerkserver liegen (Client oder Server)
  • Auf dem Server ist keine Software erforderlich
  • Bei Netzwerkanwendung werden die Daten verschlüsselt übertragen und erst auf dem Client entschlüsselt

Übersicht abylon CRYPTDRIVE Optionen

1. | Name | Angabe des Laufwerk-Namen, der im Datei Explorer angezeigt wird.
2. | Laufwerksbuchstabe | Angabe des Buchstabens unter dem das Laufwerk im Datei Explorer angezeigt wird.
3. | Größe (MB) | Eingabemöglichkeit für die Größe des Laufwerks in MB (bis 128 GB gestestet und freigegeben). HINWEIS: Die Größe kann nur beim Erstellen eines Laufwerkes angegeben werden und ist vor der Registrierung auf 100 MB begrenzt.
4. | Partials (Teile) | Anzahl der Teile, in der die Image-Datei auf der Festplatte aufgeteilt ist. HINWEIS: Die Aufteilung der großen Image-Datei ist beim Datenbackup Vorteile!
5. | ... | Öffnet einen Dialog zum selektieren des Verzeichnisses, in dem das Laufwerk (IMG-Datei) gespeichert wird.
6. | Pfad | Anzeige und direkte Eingabemöglichkeit für den Speicherort des Laufwerkes (IMG-Datei).
7. | Übernehmen / Neu anlegen | Speichert die Daten und schließt den Dialog.

Siehe auch
>> Beschreibung des abylon CRYPTDRIVE (virtuelles Laufwerk)
>> Einrichten und Verwenden des abylon CRYPTDRIVE


abylonsoft: Einstellmöglichkleiten (Übersicht)

In dieser Software werden eine Reihe von Einstellungen automatisch und für die meisten Anwender optimiert vorgenommen. Versierte Anwender können jedoch zusätzliche Optionen und Einstellungen im Dialog abylon EINSTELLUNGEN selbst vornehmen. Dazu stehen folgende Seiten zur Verfügung:
CryptDrive
Schlüsselverwaltung
Schlüsselverwaltung - HYBRID-System
Schlüsselverwaltung - SYMM-System
Schlüsselverwaltung - PKI
Administration
Allgemein
CT32 - DLL

ACHTUNG Je nach Programmversion können einzelne, nicht benötigte Seiten ausgeblendet sein!


abylonsoft: abylon EINSTELLUNGEN (Administration)

Einstellungsseite für den Administrationsmodus. Hier kann der Administrationsmodus aktiviert, der Administrationsserver festgelegt und die Protokolle (Log-Dateien) aktiviert werden. Zusätzlich kann die Software aktiviert oder deaktiviert werden und bei Netzwerkinstallationen lassen sich die lokalen Module synchronisiert.
HINWEIS Für den Administrationsmodus sind Administrationsrechte erforderlich!
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. Administrationsmodus aktivieren / deaktivieren

Aktiviert oder deaktiviert den Administrationsmodus.
Bei aktiviertem Administrationsmodus können normale Anwender (Benutzerrechte) keine kritischen Einstellungen vornehmen.
HINWEIS Bei aktiviertem Administrationsmodus werden kritische Einstellungen unter HKLM gespeichert! (Berechtigungen in der Registry beachten!)
HINWEIS Weitere administrative Einstellungen können Mithilfe der Datei UserConfig.xml (im Verzeichnis 'CONFIG' des Programmverzeichnisses) vorgenommen werden!

2. Aktualisieren

Gleicht die Einstellungen mit anderen Dialogen ab.

3. | Administrationsserver | Hier wird der Rechnername (Domäne) eingetragen, auf dem die administratorprivilegierten Einstellungen unter HKLM gespeichert werden.
4. | Module aktivieren / deaktivieren | Je nach Status werden beim Drücken dieses Schalters alle Module aktiviert bzw. deaktiviert. Dies entspricht einer Installation oder Deinstallation, ohne die Dateien zu löschen.
5. Lokale Module synchronisieren Vergleicht die lokal installierten Module (Client) mit den Modulen auf dem Server und führt gegebenenfalls ein Update durch.
HINWEIS Wenn die Sicherheitssoftware auf dem Server installiert ist und auf dem Client nur über einen Link ausgeführt wird, dann müssen einige Module der Software (z. B. Services) auf dem Client durch Kopieren verfügbar gemacht werden.
6. Module auf USB-Stick installieren /
Module auf Client installieren /
Module vom Client entfernen 		Module auf USB-Stick installieren
Erstellt eine lauffähige Version des Programms mit Ihren Einstellungen auf dem USB-Stick. Alle Module und Funktionen, die keine administrativen Rechte oder einen Service benötigen, können vom USB-Stick gestartet werden.

Module auf Client installieren
Installiert die Version von Ihrem USB-Stick auf dem Client und überträgt alle Ihre Einstellungen. Hierzu werden administrative Rechte und eine neue Registrierung benötigt!

Module vom Client entfernen
Entfernt die Software komplett mit allen Dateien und Einstellungen vom Client!

HINWEIS Dieser Schalter zeigt die Funktionen kontextsensitiv an!

7. Protokoll Aktiviert das Log für die ausgewählten Module.
ACHTUNG Abweichend von der Abbildung werden nur die Module der entsprechenden Version angezeigt!
8. | Öffnen | Öffnet den Ordner mit den gespeicherten Anwender Log-Dateien.
9. | System Öffnen | Öffnet den Ordner mit dem gespeicherten System Log-Dateien bei Netzwerkinstallationen.


abylonsoft: abylon EINSTELLUNGEN (Allgemein)

Allgemeine Einstellungsseite für Design, Sprache oder das Anzeigeverhalten von Hinweisdialogen. Hier können auch die Einstellungen importiert oder exportiert und der allgemeine Shredderlevel festgelegt werden.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. Voreinstellung

Setzt die Einstellung entsprechend der Voreinstellung zurück.

2. Aktualisieren

Gleicht die Einstellungen mit anderen Dialogen ab.

3. Dialog im XP-Design anzeigen Auswahlfeld für das Design der Programmfenster.

Zur Zeit stehen folgende Designs zur Auswahl:

  • Klassisches Design
  • XP-Design
4. Nachrichtenfenster Anzeige aller deaktivierbaren Nachrichten. Dazu muss nur in dem entsprechenden Nachrichtenfenster 'Dialog nächstes mal anzeigen' ausgeschaltet werden!
5. Sprache Auswahl der angezeigten Sprache.

Zur Zeit werden folgende Sprachen angeboten:

  • Deutsch
  • English
  • Spanisch (Beta)
6. Shredderlevel Mit dem Schieberegler kann die Stärke des Löschvorgangs von Original- und Temporärdateien festgelegt werden. Dies ist z. B. notwendig, wenn bei der Funktionalität abylon CRYPT eine Datei verschlüsselt oder bei der Funktionalität abylon EINFÜGEN eine Datei verschoben wird und die Originaldatei sicher gelöscht werden soll. Folgende Stufen sind wählbar:
  • Level 0
    Verknüpfungen entfernen (Entspricht dem normalen Löschen im Datei Explorer)
  • Level 1
    Die Daten werden 1x überschrieben (Binäre Nullen)
  • Level 2
    Die Daten werden 3x überschrieben (DOD - Standard = 1. Zufallszahlen + 2. binäres F + 3. Binäre Null)
  • Level 3
    Die Daten werden 7x überschrieben (DOD II - Standard = 3x binäre Nullen + 3x binäre F + 1x Zufallszahlen)
  • Level 4
    Die Daten werden 13x überschrieben (3x Zufallszahlen + DOD - II + 2x Zufallszahlen + 1x binäre Nullen)
  • Level 5
    Die Daten werden 35x überschrieben (Peter Gutman Methode - Beschreibung siehe Dokument)

HINWEIS Bei einem höheren Shredderlevel (Schieberegler rechts) werden die Daten sicherer gelöscht, der Löschvorgang dauert jedoch um so länger.
HINWEIS In der Version abylon SHREDDER ist dieser Schieberegler ausgeblendet. Dabei wird für abylon PASTE der Shredderlevel für Dateien verwendet.
>> siehe Shreddern von Dateien
7. Exportieren Exportiert alle wichtigen Einstellungen in eine XML-Datei, um beispielsweise auf einem weiteren Rechner oder nach einer Neuinstallation alle gewohnten Einstellungen vorzufinden.
HINWEIS Die X.509 Zertifikate aus der Windowszertifikatsdatenbank können nicht gespeichert werden und müssen separat gesichert werden (PFX-Format).
8. Importieren Importiert eine vorher gespeicherte XML-Datei zur Wiederherstellung der gesicherten Einstellungen.
HINWEIS X.509 Softwarezertifikate (PFX-Format) müssen separat installiert werden.
TIPP Zur Erleichterung der Administration kann die Einstellungsdatei auch in dem CONFIG-Verzeichnis (im Programmverzeichnis) abgelegt werden, von wo sie automatisch durch die Software geladen wird.


abylonsoft: abylon EINSTELLUNGEN (CryptDrive)

Einstellungsseite für das abylon CRYPTDRIVE, das containerbasierte, virtuelle Laufwerk zum verschlüsselten Speichern von Dateien.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. CRYPTDRIVE aktivieren / deaktivieren

Aktiviert oder Deaktiviert das abylon CRYPTDRIVE.

2. Aktualisieren

Gleicht die Einstellungen mit anderen Dialogen ab.

3. | Öffnen / Schließen | Öffnet oder schließt das in Liste 4 selektierte Laufwerk
4. Eingerichtete Verbindungen Liste der aktuell auf dem Rechner eingerichteten virtuellen Laufwerke.
Angezeigt werden die Bezeichnung des Laufwerks, der Laufwerksbuchstabe, die Größe und der Speicherort (Initialverzeichnis).

Geöffnetes CRYPTDRIVE
Geschlossenes CRYPTDRIVE

5. Verknüpfung auf dem Desktop erstellen Über diesen Menupunkt lassen sich auf dem Desktop für jedes CRYPTDRIVE Verknüpfungen (Icons) zum Öffnen und Schließen erstellen.

TIPP Die erstellten Icons können auch ins Startmenu kopiert werden, sodass die Laufwerke automatisch nach dem Booten des Rechners geöffnet werden.
6. Neu anlegen Einrichten eines neuen virtuellen Laufwerkes.
>> Hilfe zum Laufwerk hinzufügen
7. | Importieren | Importiert ein bestehendes Laufwerk (INI-Datei) von Ihrer Festplatte oder dem Server.
8. | Bearbeiten | Öffnet einen Dialog zum Ändern der Parameter des selektierten Laufwerkes.
9. | Entfernen | Löscht das Laufwerk aus der Liste (entfernen des Links) oder vernichtet das gesamte Laufwerk.
10. Passwort ändern / Default Encryption ALG ändern Ändert das "Geheimnis" des in der Liste selektierten CRYPTDRIVE
Als Geheimnis (Zugriffsberechtigung) können Passwörter, Chipkarten, USB-Sticks, CDs/DVDs oder Zertifikate verwendet werden. Die neuen Zugriffsberechtigungen werden vorher in den Einstellungen festgelegt!

Möglicher Änderungen:

  • Passwort ändern: Neues Passwort oder andere Chipkarte festlegen.
  • SYMM >> HYBRID: Wechseln von der passwortbasierten zur zertifikatsbasierten Zugriffsberechtigung.
  • HYBRID >> SYMM: Wechseln von der zertifikatsbasierten zur passwortbasierten Zugriffsberechtigung.

Übersicht Einstellungen:

Default Encyption ALG / Schlüsselverwaltung |  | Neues "Geheimnis" (Zugriffsberechtigung)
 |  | SYMM-System / Passwortbasiert | SYMM-System / Chipkarten- oder Speichermedien- basiert | HYBRID-System
Bisheriges "Geheimnis" (Zugriffs- berechtigung) | SYMM-System / Passwortbasiert | Passwort ändern | Passwort ändern | SYMM >> HYBRID
 | SYMM-System / Chipkarten- oder Speichermedien- basiert | Passwort ändern | Passwort ändern | SYMM >> HYBRID
 | HYBRID-System | HYBRID >> SYMM | HYBRID >> SYMM | Änderung im CERTMANAGER möglich

Vorgehen zum Ändern des "Geheimnisses" (Zugriffsberechtigung):

  1. Wählen der neuen Einstellung, wie das Verschlüsselungssystem (Default Encryprtion ALG) und im Fall des SYMM-Sytem optional die Schlüsselverwaltung (Passwortbasiert oder Chipkartenbasiert)
  2. Selektieren des CRYPTDRIVE in der Liste
  3. Drücken des Schalters 'Passwort Ändern', 'SYMM >> HYBRID' oder 'HYBRID >> SYMM'
    (Der Schalters wird entsprechend den Einstellungen angezeigt; siehe Tabelle)
  4. Eingabe des bisherigen "Geheimnisses" (Passwort, PIN, Chipkarte, CD/DVD oder USB-Stick)
  5. Eingabe des neuen "Geheimnisses" (Passwort, PIN, Chipkarte, CD/DVD oder USB-Stick)

HINWEIS Beim zertifikatsbasierten HYBRID-System werden die berechtigten Zertifikate im CERTMANAGER festgelegt!

11. Default Encryption ALG Eingestelltes Verschlüsselungssystem und der verwendetet Verschlüsselungsalgorithmus.

Zur Zeit mögliche Einstellungen für das Modul abylon CRYPTDRIVE:

  • SYMM-AES: Passwortbasierte symmetrische Verschlüsselung mit dem AES-Algorithmus (Schlüssellänge 256 Bit).
  • SYMM-Blowfish: Passwortbasierte symmetrische Verschlüsselung mit dem Blowfish-Algorithmus (Schlüssellänge 448 Bit).
  • HYBRID-AES: Zertifikatsbasierte asymmetrische Schlüsselverwaltung nach dem PKCS-Verfahren von RSA und interne Verschlüsslung der Daten mit dem AES-Algorithmus (Schlüssellänge 256 Bit).
  • HYBRID-Blowfish: Zertifikatsbasierte asymmetrische Schlüsselverwaltung nach dem PKCS-Verfahren von RSA und interne Verschlüsslung der Daten mit dem Blowfish-Algorithmus (Schlüssellänge 448 Bit).

HINWEIS In der SCHLÜSSELVERWALTUNG wird festgelegt, ob beim SYMM-System ein Passwort und/oder ein externes Medium verwendet wird.

12. | Entfernen | Löscht das selektierte Zertifikat aus der Liste der berechtigten Zertifikate. Das eigene Zertifikat (Basiszertifikat) kann nicht gelöscht werden, weil sonst ein Zugriff (Entschlüsselung) nicht mehr möglich ist.
13. Hinzufügen Ergänzt die Zugriffsberechtigungen um ein weiteres Zertifikat. Zum Auswählen des Zertifikates öffnet sich der abylon CERTMANAGER.
>> Hilfe zum abylon CERTMANAGER
14. | Info | Zeigt die gesamten Informationen zum selektierten Zertifikat an.
15. Zertifikatsliste Liste aller berechtigten Zertifikate, die auf das Laufwerk zugreifen können. Dies können eigene Vollzertifikate (PKCS#12) oder öffentliche Zertifikate (PKCS#7) sein, beispielsweise von einem LDAP-Server.
>> Hilfe zum LDAP Manager

Siehe auch
>> Hilfe zum Einrichten von abylon CRYPTDRIVE


abylonsoft: abylon EINSTELLUNGEN (CT32 - DLL)

Einstellungsseite zum Suchen und Festlegen der Kartenleserschnittstelle (CT32 - DLL) für Speicherchipkarten (z. B. Krankenversichertenkarten)!
HINWEIS Je nach Kartenleser kann eine aktivierte CT32-DLL zu Problemen mit nicht Speicherchipkarten (z. B. EC-Karte oder Zertifikatschipkarte) führen. In diesem Fall sollte die CT32-DLL deaktiviert werden!
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. | Suchen | Durchsucht Ihren Rechner nach einer CT32 - DLL (Kartenleserschnittstelle). HINWEIS Dieser Vorgang kann mehrere Minuten dauern.
2. | Aktualisieren | Gleicht die Einstellungen mit anderen Dialogen ab.
3. | Aktuelle CT32 - DLL | Anzeige der installierten CT32 - DLL. HINWEIS Über das Button '...' kann eine individuelle CT32 - DLL ausgewählt werden.
4. | Zurück setzen | Entfernt den eingetragen Link.
5. | Portadresse | Angabe der Portadresse des Kartenlesers. Bei 'Automatisch' durchsucht das Programm alle Ports nach dem angeschlossenen Kartenleser oder er kann hier manuell angegeben werden. Die manuelle Angabe beschleunigt den Zugriff.


abylonsoft: abylon EINSTELLUNGEN (Schlüsselverwaltung)

Übersichts- und Infoseite für die Schlüsselverwaltung mit Erklärungen zum HYBRID- und SYMM-System.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. HYBRID-System / SYMM-System

Wechselt die Voreinstellung für alle Module zwischen dem HYBRID- (Unternehmen) und SYMM-System (Privatanwender).

2. Aktualisieren

Gleicht die Einstellungen mit anderen Dialogen ab.

3. Privatanwender (Passwortbasiert) SYMM-System - Einstellung empfohlen für Privatpersonen und kleine Unternehmen:

Bei der symmetrischen Verschlüsselung (SYMM-System) werden Daten mit einem Geheimnis verschlüsselt. Bei diesem Geheimnis kann es sich um ein Passwort oder bei dieser Software auch um eine Chipkarte (z. B. EC-Karte) handeln. Für die Entschlüsselung der Daten muss das Geheimnis bekannt sein, also das Passwort eingegeben oder die Chipkarte eingelegt werden. Als symmetrische Verschlüsselungsverfahren können der Blowfish- und AES-Algorithmus ausgewählt werden.

>> Weitere Einstellungen zum SYMM-System

4. Unternehmen (X.509 Zertifikatsbasiert) HYBRID-System - Einstellung empfohlen für Unternehmen:

Die asymmetrische Verschlüsselung basiert auf X.509 Zertifikaten, welche einem zusammengehörenden Schlüsselpaar entsprechen. Mit dem öffentlichen Schlüssel werden die Daten verschlüsselt und können nur mit dem privaten Schlüssel wieder entschlüsselt werden. Eine Entschlüsselung mit dem öffentlichen Schlüssel ist nicht mehr möglich. Durch die hohe Komplexibilität wird die asymmetrische Verschlüsselung in der Regel mit einem symmetrischen Verschlüsselungsverfahren (hier Blowfish oder AES) kombiniert, weshalb es auch als Hybridverfahren (HYBRID-System) bezeichnet wird.

Mit Zertifikaten können Daten auch signiert, also elektronisch unterschrieben werden.

DIESE OPTION SETZT EIN SOFTWAREZERTIFIKAT ODER EINE ZERTIFIKATSCHIPKARTE (TOKEN) VORAUS!

>> Weitere Einstellungen zum HYBRID-System

5. Beim Ziehen der Karte bzw. SHIFT + ESC Verhalten beim Ziehen einer Karte/USB-Stick oder wenn die Tastenkombination SHIFT + ESC gedrückt wird.

Mögliche Aktionen:

  • Keine Aktion
    Es wird keine Aktion ausgeführt!
  • USB-Stick nur deaktivieren
    Deaktiviert alle USB-Sticks, um Sie vom Computer entfernen zu können!
  • Geöffnete Objekte nur Schließen
    Schließt alle CRYPT-Objekte (z. B. alle geöffneten CRYPTDRIVES), sodass kein Zugriff mehr möglich ist!
  • Computer nur Sperren
    Sperrt den Computer !
  • USB-Stick deaktivieren und geöffnete Objekte schließen
    Deaktiviert alle USB-Sticks und schließt die offenen CRYPT-Objekte!
  • USB-Stick deaktivieren, geöffnete Objekte schließen und Computer Sperren
    Deaktiviert alle USB-Sticks, schließt die offenen CRYPT-Objekte und sperrt den Computer in einem Rutsch!
  • Reset Datei Explorer
    Führt einen Neustart des Datei Explorer durch.

Siehe auch
>> Hilfe zum abylon CERTMANAGER

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 17.09.2002 your Webmaster!

Last Update / Stand 31.03.2006


abylonsoft: abylon EINSTELLUNGEN (Schlüsselverwaltung - HYBRID-System)

Einstellungsseite für die asymmetrische Verschlüsselung nach dem HYBRID-System. Hier kann der Verschlüsselungs- und Signaturalgorithmus festgelegt und getestet, sowie der Zertifikatsmanager geöffnet werden.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. | Zertifikatsmanager | Öffnet den abylon CERTMANAGER, die Schaltzentrale für alle Zertifikate und Berechtigungen.
2. | Aktualisieren | Gleicht die Einstellungen mit anderen Dialogen ab.
3. | Zertifikatsmanager als Systemuser | Öffnet den abylon CERTMANAGER als Systemuser. HINWEIS In diesem Kontext eingetragene Zertifikate können beispielsweise beim abylon LOGON Modul zu Fehlern und Problemen führen.
4. | Encryption (RSA-OIDs) | Auswählen des verwendeten Verschlüsselungsalgorithmus beim HYBRID-System. HINWEIS Der gewählte Verschlüsselungsalgorithmus muss vom CSP und dem Zertifikat unterstützt werden und kann mit Schalter 6 getestet werden. TIPP Für weitere Informationen siehe PKCS-Handbuch (http://www.rsa.com)
5. | Signature (RSA-OIDs) | Auswählen des verwendeten Signaturalgorithmus beim HYBRID-System. HINWEIS Der gewählte Signaturalgorithmus muss vom CSP und dem Zertifikat unterstützt werden und kann mit Schalter 6 getestet werden. TIPP Für weitere Informationen siehe PKCS-Handbuch (http://www.rsa.com)
6. | Einstellungen mit CSP testen | Der Crypto Servie Provider CSP ist für den Zugriff der Anwendungen auf der Zertifikat zuständig. Nicht jeder CSP unterstütz dabei alle Verschlüsselungs- und Signaturalgorithmen, sodass dieser mit den unter Punkt 4 und 5 gewählten Einstellungen getestet werden kann.

Siehe auch
>> Hilfe zum abylon CERTMANAGER


abylonsoft: abylon EINSTELLUNGEN (Schlüsselverwaltung - PKI)

Einstellungsseite für die Small PKI und dateibasierte Zertifikatsdatenbank (Datei PKI) für den Austausch auf öffentliche Schlüssel. Diese werden im abylon CERTMANAGER als zusätzliche Punkte angezeigt und ermöglichen in Netzwerken den einfachen Austausch von öffentlichen Schlüsseln. Hiermit ist es jedem Anwender möglich auf öffentliche Schlüssel von beispielsweise Mitarbeitern zuzugreifen und für Ihn Daten zu verschlüsseln. Auch bei der gemeinsamen Benutzung von einem abylon SHAREDDRIVE (HYBRID-System) muss von jedem berechtigten Anwender auf allen Rechnern der öffentliche Schlüssel verfügbar sein.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. | Small PKI aktivieren / deaktivieren | Aktiviert oder Deaktiviert die Small PKI und die dateibasierte Datenbank (Datei PKI) im abylon CERTMANAGER.
2. | Aktualisieren | Gleicht die Einstellungen mit anderen Dialogen ab.
3. | Small PKI Server | Eingabefeld für den Server, auf dem in der Registry unter HKLM alle Zertifikate gespeichert werden.
4. | Verfügbare Datenbanken | Anzeige aller verfügbaren Windows-Zertifikatsdatenbanken auf dem unter Punkt 3 angegebenen Server.
5. | Hinzufügen | Fügt die links selektierte Datenbank der rechten Liste hinzu. HINWEIS In der Regel ist die Zertifikatsdatenbank 'MY' ausreichend!
6. | Entfernen | Löscht die rechts in der Liste selektierte Datenbank.
7. | Anzuzeigende Datenbanken | Diese Datenbanken werden im abylon CERTMANAGER unter Small PKI angezeigt.
8. | Dateibasierte Zertifikatsdatenbank (Datei PKI) | Um unabhängig von der Windows-Zertifikatsdatenbank zu sein, können die Zertifikate auch in einer Datei abgelegt werden. Diese Datei kann sich beispielsweise auch auf dem Server befinden, sodass alle Anwender im Netzwerk auf die selben Zertifikate zugreifen können. HINWEIS Zur Zeit werden nur öffentliche Schlüssel in dieser Datenbank abgelegt. Die privaten Schlüssel müssen lokal verfügbar sein, z. B. als Softwarezertifikat oder auf einem externen Token!

Beschreibung und Einsatz:

Small PKI Die Anbindung an die netzwerkinterne Public Key Infrastruktur (Small PKI) von abylonsoft ermöglicht den zentralen Zugriff auf alle benötigten Zertifikate (öffentliche Schlüssel). Gerade in kleineren und mittleren Netzwerken (bis zu 50 Rechnern) wird der administrative Aufwand deutlich reduziert und macht zudem den kostenintensiven Einsatz von aufwendigen LDAP-Servern überflüssig.

Bei Aktivierung wird im abylon CERTMANAGER zusätzlich der Punkt Small PKI angezeigt, auf dem alle Anwender (auch übers Netzwerk) zugreifen können. Dazu werden die Zertifikate auf dem Server (Punkt 3) in der Registry unter HKLM gespeichert. (Berechtigungen in der Registry beachten!)
Dateibasierte Zertifikatsdatenbank (Datei PKI) Die Datei PKI ermöglicht wie die Small PKI den zentralen Zugriff auf die öffentlichen Schlüssel. Hierbei werden die Zertifikate jedoch in einer Datei (Dateierweiterung STO) gespeichert, welche sowohl lokal auf dem Computer oder auf einem Netzwerkrechner liegen kann.

Bei Aktivierung wird im abylon CERTMANAGER zusätzlich der Punkt Datei PKI angezeigt, auf dem alle Anwender (auch übers Netzwerk) zugreifen können. Der Speicherort wird unter Punkt 8 angegeben.

TIPP Die dateibasierte Datenbank kann auch zentral von einem Administrator verwaltet werden und bei Änderungen lokal auf die einzelnen Rechner verteilt werden. Hierdurch ist auch der Einsatz ohne permanenten Netzwerk-Anschluss (z. B. Notebooks) möglich.

Administration der PKI Die Small und Datei PKI werden im abylon CERTMANAGER als separate Punkte angezeigt. Die Zertifikate (nur öffentliche Schlüssel) lassen sich hier Einfügen oder von hier Kopieren. Dazu selektieren Sie einfach das gewünschte Zertifikat, drücken die rechte Maustaste und klicken im Menu auf den Eintrag Kopieren oder Einfügen. Damit bietet sich eine zentrale Schnittstelle für den Zugriff auf öffentliche Schlüssel.

Siehe auch
>> Hilfe zum abylon CERTMANAGER
>> Austausch von öffentlichen Schlüsseln


abylonsoft: abylon EINSTELLUNGEN (Schlüsselverwaltung - SYMM-System)

Einstellungsseite für die Schlüsselverwaltung des SYMM-Systems. Hier kann festgelegt werden, ob die Dateien mit Passwort und/oder Chipkarte verschlüsselt werden sollen.
ACHTUNG Je nach Version können einzelne Optionen nicht verfügbar sein bzw. voneinander abweichen!

1. | Passwortbasiert / Kartenbasiert | Wechselt die Standarteinstellungen zwischen passwortbasierte und kartenbasierte Schlüsselverwaltung
2. Aktualisieren

Gleicht die Einstellungen mit anderen Dialogen ab.

3. | Passwortbasierte Schlüsselverwaltung | Beim SYMM-System erfolgt die Sicherheit (Verschlüsselung oder Zugriffskontrolle) durch die Eingabe eines Passwortes über einen Passwortdialog (empfohlen für Anwender, die Ihr Passwort stets über die Tastatur eingeben möchten).
4. Chipkarten- oder Speichermedienbasierte (USB-Stick) Schlüsselverwaltung Beim SYMM-System erfolgt die Sicherheit (Verschlüsselung oder Zugriffskontrolle) durch die Verwendung einer Chipkarte, USB-Tokens, einer CD/DVD oder eines externen Speichermediums. Ein Passwort ist nicht erforderlich!

Zur Zeit unterstützte Medien:

  • USB-Speichermedien
    HINWEIS Bisher sind noch keine Einschränkungen bei handelsüblichen USB-Speichermedien bekannt, wie z. B. USB-Stick, CompactFlash, MemoryStick oder Multimedia-Karte!
  • EC-/HBCI-Karte mit Chip
    HINWEIS Für die EC-/HBCI-Karte wird eine PC/SC-Schnittstelle benötigt.
  • Speicherchipkarten (z. B. Krankenversichertenkarte)
    HINWEIS Für die Speicherchipkarten benötigen Sie eine CT32-API (Schnittstellen-DLL).
    >> Hilfe zu CT32 - DLL Einrichtung
  • CD/DVD

HINWEIS siehe auch Punkt 6 SecureID anfordern.

5. Chipkarten- oder Speichermedien basierte (USB-Stick/CD) Schlüsselverwaltung mit Passwortabfrage Beim SYMM-System erfolgt die Sicherheit (Verschlüsselung oder Zugriffskontrolle) durch die Verwendung einer Chipkarte, USB-Tokens, einer CD/DVD oder eines externen Speichermediums. Für eine erweiterte Sicherheit muss zusätzlich ein Passwort eingegeben werden!

Zur Zeit unterstützte Medien:

  • USB-Speichermedien
    HINWEIS Bisher sind noch keine Einschränkungen bei handelsüblichen USB-Speichermedien bekannt, wie z. B. USB-Stick, CompactFlash, MemoryStick oder Multimedia-Karte!
  • EC-/HBCI-Karte mit Chip
    HINWEIS Für die EC-/HBCI-Karte wird eine PC/SC-Schnittstelle benötigt.
  • Speicherchipkarten (z. B. Krankenversichertenkarte)
    HINWEIS Für die Speicherchipkarten benötigen Sie eine CT32-API (Schnittstellen-DLL).
    >> Hilfe zu CT32 - DLL Einrichtung
  • CD/DVD

HINWEIS siehe auch Punkt 6 SecureID anfordern.

6. SecureID anfordern Liefert ein 64stellige SecureID für alle unterstützen Chipkarten (EC-/KV-Karte) und USB-Speichermedien.
Sollte Ihre Chipkarte/USB-Speichermedium defekt oder nicht mehr auffindbar sein, dann können Sie mit Hilfe der entsprechenden SecureID auf Ihre Daten zugreifen (z. B. Dateien Entschlüsseln, Laufwerke oder Passworttresor öffnen).
HINWEIS Hinterlegen Sie aus Sicherheitsgründen jede SecureID an einen sicheren Ort.
7. Einstellungen Für die Chipkarten- und Speichermedienbasierte Schlüsselverwaltung können hier einzelne Medien aktiviert und deaktiviert werden.

Zur Zeit unterstützte Medien:

  • CD/DVD
  • Prozessorchipkarten (z. B. EC-Karte, Zertifikatschipkarte (SCARD))
  • Speicherchipkarte (z. B. Krankenversicherten-Karte (CT32))
  • USB-Stick und / oder Memoryflash-Karten
8. SecureID anfordern Falls beispielsweise mehrere Kartenleser am Rechner angeschlossen sind, so kann hier die Auswahl weiter eingeschränkt werden.
  • ANY CARDREADER
    Die Software reagiert auf alle Kartenleser, CD/DVD-Laufwerke und USB-Speichermedien!
  • Spezielles Device
    Die Software reagiert nur auf das ausgewählte Device.

HINWEIS Zur individuellen Auswahl muss das entsprechende Device gesteckt sein oder eine CD/DVD einliegen!

Siehe auch
>> Hilfe zum abylon CERTMANAGER


abylonsoft: abylon KEYGENERATOR

Nur abylon ENTERPRISE Im Funktionsumfang dieser Version und abylon KEYSAFE Im Funktionsumfang dieser Version
Beschreibung des abylon KEYGENERATOR
 Der abylon KEYGENERATOR wird über den abylon KEYSAFE aufgerufen und generiert vollkommen zufällige Passwörter (Kennwörter) anhand ihrer Mausbewegung. Nach Fertigstellung des Passwortes wird dieses automatisch in das entsprechende Feld des abylon KEYSAFE eingetragen. Zusätzlich können Sie im Vorfeld selbst Randbedingungen für die Generierung Ihres Passwortes festlegen, so können zum Beispiel Sonderzeichen ausgeschlossen werden.

Funktionsumfang:

  • Erstellen von zufälligen Passwörtern aufgrund der Mausbewegung
  • Auswahlmöglichkeit der Zeichentypen
  • Anzeige der Sicherheit des erzeugten Passwortes

Übersicht abylon KEYGENERATOR

1. | Anzahl der Zeichen | Festlegen der gewünschten Kennwortlänge mit Hilfe der Schalter am rechten Rand des Feldes.
2. | Zeichen Typen | Auswahl der Zeichen, die im generierten Passwort verwendet werden sollen.
3. | Sicherheit | Anzeige der Passwortsicherheit entsprechend der Passwortlänge und der zu verwendenden Zeichen.
4. | Fortschrittsanzeige | Hier wird die Dauer der Passwortgenerierung angezeigt. Wenn der Balken das rechte Ende erreicht hat, dann ist das Kennwort fertig generiert.
5. | Mauszeigerfeld | Zur Generierung des Passwortes müssen Sie den Mauszeiger in diesem Feld bewegen. Anhand der Koordinaten wird das Kennwort rein willkürlich erzeugt.
6. | Passwort erzeugen | Wenn alle Parameter festgelegt wurden, wird mit diesem Schalter die Passwortgenerierung gestartet. Danach müssen Sie nur noch den Mauszeiger im Feld 5 bewegen, bis der Balken 4 das rechte Ende erreicht hat.

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 16.09.2002 your Webmaster!


abylonsoft: abylon SELFCERT

Beschreibung abylon SELFCERT
Dieses Tool ermöglicht die Erstellung von selbstsignierten Testzertifikaten (X.509 v3), wodurch Ihnen der umständliche und kostspielige Weg zu einer CA (Zertifikatsaussteller) erspart bleibt.

Funktionsumfang:

  • Erstellung von selbstsignierten X.509 v3 Testzertifikaten
  • Nach der Erstellung des Zertifikates ist eine automatische Installation möglich
  • Zertifikatsfelder: Inhaber, Emailadresse, Land, Stadt, Organisation und Department
  • Schlüsselstärke von 512 bis 4096 Bit
  • Laufzeit bis 9999 Tage (~27 Jahre)

Übersicht abylon SELFCERT

1. | Zertifikatsinhaber | Angabe Ihres Namen, der im Zertifikat verwendet werden soll
2. | Emailadresse | Angabe Ihre Emailadresse, die im Zertifikat verwendet werden soll
3. | Staat/Provinz | Angabe des Region/Bundesland
4. | Stadt | Angabe des Wohnortes oder des Sitzes der Organisation
5. | Organisation | Angabe der Behörde, der Firma oder der Vereinigung
6. | Department | Angabe der Abteilung (Department)
7. | Land | Auswahlliste des Landes
8. | Seriennummer | Zufällig generierte Seriennummer, die auch frei gewählt werden kann.
9. | RSA Schlüssellänge | Länge des generierten Schlüssels in Bit (512, 1024, 2048, 3072, 4096). HINWEIS Je größer die Schlüssellänge, um so sicherer sind Ihre Daten, jedoch sind die Verschlüsselungsoperationen aufwendiger und benötigen länger (1024 Bit Schlüssellänge sind zur Zeit Standard und 2048 Bit entspricht militärischer Verschlüsselung).
10. | Laufzeit (Tagen) | Gültigkeitslänge des erstellten Zertifikats in Tagen
11. | Alias | Angabe des Namen in Kurzform, eines Kürzels oder eines Spitznamen.
12. | Erstellen | Mit diesem Button starten Sie die Generierung des selbstsignierten Testzertifikaten (X.509 v3). Diese Zertifikate sind nur für die private Verwendung vorgesehen.

Siehe auch
>> Hilfe zur Erstellung eines Zertifikates
>> Hilfe zur Installation eines Zertifikates


abylonsoft: abylon ZERTIFIKATSPRÜFUNG

Nur abylon ENTERPRISE Im Funktionsumfang dieser Version, abylon KEYSAFE Im Funktionsumfang dieser Version, abylon CRYPTDRIVE Im Funktionsumfang dieser Version und abylon SHAREDDRIVE Im Funktionsumfang dieser Version
Beschreibung der abylon ZERTIFIKATSPRÜFUNG
 Im Fall des HYBRID-Systems werden alle Zugriffe und Berechtigungen über Zertifikate geregelt. Über den abylon CERTMANAGER können Sie diese Berechtigungen jederzeit neu vergeben. Aus Sicherheitsgründen wird beim ersten Öffnen des entsprechenden Elementes eine genaue Prüfung durchgeführt. Sollte sich die Liste der berechtigten Zertifikate geändert haben, so werden Sie auf evtl. Änderung in diesem Dialog hingewiesen. Sie sollten sich die Liste der Zertifikate genau ansehen, um zu verhindern das Ihnen ein Hacker etc. ein Zertifikat untergemogelt hat. Hier besteht noch einmal die Möglichkeit dieses unberechtigte Zertifikat zu löschen. Ferner prüft der Dialog, ob alle eingetragenen Zertifikate wirklich auf Ihrem System installiert sind. Sollte ein Zertifikat in der Zwischenzeit gelöscht worden sein, so wird dieses hier angezeigt und Sie müssen es explizit aus der Liste der berechtigten Zertifikate entfernen.

Übersicht abylon ZUGRIFFSPRÜFUNG von Zertifikaten

1. | Hinweis | Anzeige von allgemeinen Informationen.
2. | CERTMANAGER | Ruft den abylon CERTMANAGER auf.
3. | Entfernen | Entfernt ein nicht berechtigtes bzw. ein nicht vorhandenes Zertifikat aus der Liste der berechtigten Zertifikate.
4. | Info | Zeigt detaillierte Informationen zu den Zertifikaten in Liste 5 an.
5. | Berechtigte(s) Zertifikat(e) | Anzeige einer Liste von Zertifikaten, die z. B. berechtigt sind auf den abylon KEYSAFE, ein abylon CRYPTDRIVE oder abylon SHAREDDRIVE zuzugreifen. HINWEIS Sie sollten die Liste genau überprüfen und notfalls unberechtigte Zertifikate löschen.
6. | Weiter | Mit 'Weiter' bestätigen Sie die Änderungen der Zugriffsberechtigungen.

Fragen, Anregungen und Kritik bitte an: Kontakt
Disclaimer | Impressum | AGB

(c) 2001-2006 abylonsoft - created 16.09.2002 your Webmaster!


abylonsoft: Lexikon

1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
2DES
(siehe DES)

3DES
(siehe DES)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
AES
(Advanced Encryption Standard) [symmetrische Verschlüsselung] ist das offizielle Nachfolgeverfahren von DES. Bei einem Wettbewerb im Jahre 2000 hat sich schließlich der belgische Algorithmus RIJNDAEL durchgesetzt. Die Juroren begründeten ihre Entscheidung mit den Argumenten, Rijndael sei sicher, verhältnismäßig leicht in Soft- und Hardware zu implementieren und es biete somit ausreichenden Schutz für die nächsten 100 Jahre. (Das ist natürlich eine grobe Schätzung)
(siehe auch DES, symmetrische Verschlüsselung)

ASN.1
(Abstract Syntax Notation One) ist ein systemtunabhängiges Datenformat, was zum Datenaustausch von Informationen zwischen verschiedenen Systemen verwendet wird)

Asymmetrische Verschlüsselung

Im Gegensatz zur symmetrischen Verschlüsselung (Sectret Key Verfahren) mit Ihrem unsicheren Schritt des Schlüsselaustausches bietet die asymmetrische Verschlüsselung (Public Key Verfahren) durch die Verwendung eines Schlüsselpaares (privater und öffentlicher Schlüssel) die Möglichkeit der sicheren Kommunikation über unsichere Kommunikationswege (Internet). Mit dem allgemein zugänglichen öffentlichen Schlüssel (Bild: rot) von Person A wird die Datei verschlüsselt. Danach ist ein sicherer Datenaustausch auch über unsichere Kanäle wie das Internet möglich, denn nur Person A kann mit seinem privaten (geheimen) Schlüssel (Bild: blau) die Datei entschlüsseln.

Ausführlich:
Von den genannten Verschlüsselungsverfahren (asymmetrische und symmetrische) ist das asymmetrische Verschlüsselung (Public Key Verfahren) auf jedem Fall die sichere Methode. Der Nachteil ist der hohe mathematische Aufwand und damit die Schwierigkeit, große Datenmengen ONLINE zu verschlüsseln. Aus diesem Grund wird in der Regel ein Hybridverfahren verwendet, wobei symmetrische und asymmetrisch (Public Key Verfahren) Verschlüsselung (Secret Key Verfahren) kombiniert werden. Wie der Name Secret Key schon sagt, darf der Schlüssel bei den symmetrischen Verfahren keinem anderen als Dir bekannt sein. Beim Hybridverfahren wird zuerst mit einem Zufallsgenerator ein Passwort (Secret Key) erzeugt, mit dem dann nach einem symmetrischen Verschlüsselungsverfahren (z. B. 3DES) die Daten verschlüsselt werden. Dies geht relativ schnell. Danach wird nur das Zufallspasswort (Secret Key) mit einem öffentlichen Schlüssel (Public Key) nach dem asymmetrischen Verfahren verschlüsselt und an die Datei angehangen. Nur der Empfänger, der im Besitz des entsprechenden privaten Schlüssels (Privat Key) ist, kann damit das Passwort (Secret Key) entschlüsselt. Dadurch ist er nun in der Lage die kompletten Daten zu entschlüsseln. Der Vorteil bei diesem Hybridverfahren ist, dass das Passwort nicht unverschlüsselt über öffentliche Kanäle (Internet, Telefon) übermittelt werden muss und sich zudem bei jeder Session (Verschlüsselung) ändert. Außerdem werden hierbei die hohe Geschwindigkeit der symmetrischen Verschlüsselung mit der hohen Sicherheit und Bedienerfreundlichkeit der asymmetrischen Verschlüsselung kombiniert. Der Private Key (private Schlüssel) gehört immer mit dem Public Key (öffentlicher Schlüssel) zusammen. Wir sprechen hier auch von einem Schlüsselpaar, welche beide für eine Ver- und Entschlüsselung nach dem asymmetrischen Verfahren notwendig sind. Daten, die mit dem öffentlichen Schlüssel (Public Key) von A verschlüsselt worden sind, können nur mit dem privaten Schlüssel (Private Key) von A wieder entschlüsselt werden.

Wie das Passwort (Secret Key) bei der symmetrischen Verschlüsselung, darf der private Schlüssel (Private Key) bei der asymmetrischen Verschlüsselung niemand anderem als dem Inhaber bekannt sein (->sicher aufbewahren). Der Vorteil bei dem Schlüsselpaar ist, dass der private Schlüssel nicht übertragen werden muss, wie das Passwort bei der symmetrischen Verschlüsselung. Selbst wenn ich das Passwort (Secret Key) persönlich meinem Partner aushändige, so ist doch schon mind. 1 fremde Person im Besitzt des Passwortes. Aus diesem Grund ist es bei der symmetrischen Verschlüsselung am sinnvollsten mit jedem Partner ein eigenes Passwort festzulegen. Dies wird um so komplizierter, je mehr Passwörter man sich merken muss.

Welche Rolle spielt nun das Hashverfahren in diesem Fall? - Das Hashverfahren ist kein Ver- oder Entschlüsselungsverfahren. Es wird nach einem mathematisch festgelegten Mechanismus (Hashverfahren) eine Art "Quersumme" über die Daten gebildet. Unabhängig von der Länge der Daten (100 Byte, 1000 Byte oder 1 MByte), wird ein fester Fingerabdruck dieser Daten mit einer festen Länge von z. B. 160 Bit (RipeMD160) gebildet.
Wenn nun z. B. einen Hashwert über eine Email gebildet wird und sich nur ein Zeichen in der Email ändert, dann verändert sich auch der Hashwert. Der Hashwert beinhaltet keine großen Datenmengen und kann so vor der Übertragung mit einem asymmetrischen Schlüsselverfahren ONLINE verschlüsselt werden. Nur der Empfänger dieser Email kann nun mit seinem privaten Schlüssel (Private Key) den ursprünglichen Hashwert wieder herstellen und prüfen. Der Empfänger kann nun seinerseits wieder einen Hashwert über ihre Daten (Email) bilden und vergleicht diesen mit dem verschlüsselt übertragenden Hashwert. Stimmen beide Werte überein, so wurde ihre Email oder die Daten unterwegs nicht verfälscht.
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Blowfish
ist ein frei einsetzbares Verschlüsselungsverfahren mit einer variablen Schlüssellänge von 32 bis 448 Bit. Durch die hohe Schlüssellänge zählt Blowfish als relativ sicher. (siehe auch symmetrische Verschlüsselung)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Chiffrieren
ist französisch und bedeutet Verschlüsseln (siehe auch Asymmetrische Verschlüsselung, Symmetrische Verschlüsselung, Verschlüsseln)

Certification Authority (CA)
(siehe Trustcenter)

CSP (Cryptographic Service Provider)
Schnittstelle (Treiber) zwischen dem Zertifikat auf der Chipkarte, dem Chipkartenleser und der Microsoft Zertifikatsdatenbank bzw. der entsprechenden Anwendung.
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Dekodieren
(siehe Entschlüsseln)

DES
(Data Encryption Standard) [symmetrische Verschlüsselung] verschlüsselt mit einem 56 Bit-Schlüssel durch vertauschen und ersetzen einzelner Bits in 16 Durchläufen. Inzwischen wird DES nicht mehr als unbedingt sicher betrachtet. Um den erhöhten Sicherheitsanspruch weiter gerecht zu werden, wurde das 3DES (TripelDES)-Verfahren eingeführt. Der Unterschied ist, dass die Schlüsselstärke von 56bit (DES) auf 112bit (2DES) bzw. 168bit (3DES) angehoben wurden. DES ist aufgrund der Geschwindigkeit sehr gut für Onlineverschlüsselung (z. B. im Internetbanking) geeignet. Das Zahlungssystem SET, die Emailverschlüsselung S/MIME und stellenweise auch SSL arbeitet auf der Basis von DES!

Diffie-Hellmann
ist ein Key - Austausch - Protokoll. Es wurde 1976 von Whitfield Diffie and Martin E. Hellman entwickelt und dient zum sicheren Austausch von Schlüsseln (Public- und Private-Key). Die Schlüssellänge bei DH variiert von 512 bis 8192 Bits. (siehe asymmetrische Verschlüsselung)

Digital Envelope (SME - Datei)
Ein digitaler Briefumschlag (Digital Envelope) ist das elektronische Gegenstück eines normalen Briefes. Hierbei werden zuerst die Daten signieren, welches der Unterschrift auf dem Brief gleicht. Das Einkuvertieren entspricht letztendlich dem Verschlüsseln der signierten Daten. Jetzt können Sie ohne Angst zu haben, die Daten über unsichere Kanäle (Internet, Email) verschicken. Der Empfänger benötigt nun den richtigen Schlüssel, um die Daten wieder zu entschlüsseln. Durch die Kontrolle der Signatur (Unterschrift) ist er zudem sicher, dass die Daten unterwegs nicht verändert wurden und das diese vom richtigen Absender stammen.
Eine normale, unverschlüsselte Email würde im Alltag einer offenen Postkarte entsprechen, die ungeschützt durchs weltweite Datennetz wandert. Jeder etwas versierte User kann diese abfangen und lesen, wie der Postbote eine Postkarte. (siehe auch asymmetrische Verschlüsselung, Hash Wert)

DoD - Methode
ist eine standardisierte Methode zum Löschen von Daten auf der Festplatte, um eine nicht gewünschte Wiederherstellung zu verhindern. Bei der DoD - Methode werden die Daten in der Reihenfolge binäre Nullen, binäre Einsen und Zufallszahlen überschrieben. Bei der DOD II - Methode wird die DOD - Methode zweimal angewendet, wodurch die Daten insgesamt 6 mal überschrieben werden. Diese Löschmethoden werden bei den Produkten von abylonsoft eingesetzt. (siehe auch Peter Gutman - Methode)

DSS
(Digital Signature Standard) (siehe Asymmetrische Verschlüsselung)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Entschlüsseln
Beim Entschlüsseln oder Dekodieren wird die aus der Verschlüsselung hervorgehenden nichtlesbaren Daten in lesbare umgewandelt. Dabei wird je nach Verschlüsselungsart ein Schlüssel in Form eines Passwortes benötigt. Handelt es sich bei der Verschlüsselung um eine asymmetrische Verschlüsselung, benötigt man zum Entschlüsseln den entsprechenden privaten Schlüssel. (siehe auch Asymmetrische Verschlüsselung, Symmetrische Verschlüsselung, Verschlüsseln)

ETSI/GSM 11.11
Standard für das digitale Mobilfunknetz GSM (D-Netz)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
geheimer Schlüssel
(siehe Secret Key Verfahren, Symmetrische Verschlüsselung)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Hashverfahren
(siehe Asymmetrische Verschlüsselung und Hash Wert)

Hash Wert
Bei so genannten 'Hashen' wird eine Art "Quersumme" über die Daten gebildet. Das Ergebnis ist je nach Hashverfahren ein Ergebnis fester Länge (z. B. 160 Bit). Egal, ob ihre Daten nun 1KByte oder 1MByte groß sind. Dieses Hashergebnis ist vergleichbar mit einem Fingerabdruck der Daten. Wenn Du nun auch nur ein Zeichen in ihren Daten (z. B. Worddokument) änderst und wieder einen Hashwert bildest, ist dieser anders als der Erste. Du kannst also mit Hilfe des Hashwertes feststellen, ob irgendwas an ihren Daten (z. B. während einer Übertragung) verändert worden ist. Andererseits kann aufgrund des Hashwertes nicht auf den Inhalt der Daten geschlossen werden, denn verschiedene Daten können den gleichen Hashwert besitzen (z. B. Quersummen von 16, 25 und 34 sind alle 7). Bei einer Länge von 160 Bits ist jedoch die Möglichkeit auf die ursprünglichen Daten zu schließen so gut wie unmöglich.
Bekannte Hashverfahren: MD5 (Message Digest) -> 128 Bit; SHS/SHA (Secure Hash Standard/Algorithm) -> 160 Bit

HYBRID-System
Die Software von abylonsoft unterscheidet ab der Version 5.3 bei der Verschlüsselung von Daten zwischen dem HYBRID- und SYMM-System. Beim HYBRID-System erfolgt die Verschlüsselung auf der Basis des PKCS-Standards von RSA mit Hilfe von X.509-Zertifikaten. Dabei wir der SessionKey mit dem öffentlichen Schlüssel (Publik Key) des Zertifikates verschlüsselt und die Entschlüsselung erfolgt mit dem privaten Schlüssel (Private Key) des Zertifikates. Die Daten werden schließlich nach einem symmetrischen Algorithmus (z. B. AES oder Blowfish) und dem SessionKey als Passwort verschlüsselt. (siehe auch SYMM-System, asymmetrisch Verschlüsselung, PKCS, RSA, X.509-Zertifikaten)

Hybridverfahren
Kombination aus symmetrischer und asymmetrischer Verschlüsselung (siehe asymmetrisch Verschlüsselung)

1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
IDEA
(Internatial Data Encryption Algorythm) [symmetrische Verschlüsselung] Hierbei werden wie bei DES-Verfahren die Daten in 16 Durchläufen durch vertauschen und ersetzen einzelner Bits mit einem 128 Bit-Schlüssel verschlüsselt.

ISO 7810-7813
Normen für Identifikationskarten (Plastikkarten): Physikalische Eigenschaften, Hochprägung, Magnetstreifen, Aufzeichnungstechnik, Lage der Elemente, Nummernsystematik

ISO 7816-1,2
Physikalische Eigenschaften von Chipkarten, Abmessungen und Lage der Kontakte. (siehe auch Prozessorchipkarten)

ISO 7816-3
Elektrische Eigenschaften der Kontakte, Kommunikationsprotokolle. (siehe auch Prozessorchipkarten)

ISO 7816-4
(vorl.) Kommunikationsinhalte, Datenstruktur der Chipkarte, Sicherheitsarchitektur, Zugriffsmechanismen. (siehe auch Prozessorchipkarten)

ISO 7816-5
(vorl.) Aufbau von Applikationen, Wahl und Ausführung von Applikationen, Registrierung von Applikationen (Nummernsystematik). (siehe auch Prozessorchipkarten)

Intelligente Speicherchipkarten
Bei intelligenten Speicherchipkarten ist der Speicher (EPROM oder EEPROM) nur über eine festverdrahtete Sicherheitslogik zugänglich. Anwendung als Debitkarte (Telefonkarte). (siehe auch Speicherchipkarten)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Kodieren
(siehe verschlüsseln)

Kryptographie
Der Begriff Kryptographie bezeichnet die Lehre zur systematischen Verschleierung von Nachrichten durch Verschlüsseln. Die Originaldaten werden dabei mit Hilfe eines Algorithmus unleserlich gemacht (chiffriert) und können nur durch Kenntnis des speziellen Schlüssels wieder hergestellt werden. Erste Anwendungen der Kryptographie sind schon aus der Zeit weit vor Christi Geburt überliefert. Im 2. Weltkrieg war z. B. die Entschlüsselung der Chiffriermaschine Enigma durch die Engländer von entscheidender Bedeutung. Heutzutage unterteilt man die Kryptographie in die zwei großen Teilgebiete asymmetrische und symmetrische Verschlüsselung. (siehe auch Verschlüsseln, asymmetrische Verschlüsselung, Symmetrischen Verschlüsselung)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
LDAP
Das Lightweight Directory Access Protokoll (LDAP) ist ein IBM-Standard für die Kommunikation von Rechnern mit einer Datenbank über das Internet. Dabei wurde der umfangreiche X.500 Directory Service abgespeckt, um auch bei schmaler Bandbreite eine zügige Kommunikation zu erlauben. Einträge in einem LDAP- oder X.500-Verzeichnis erlauben eines Zugriff über ein Netzwerk oder auch das Internet zum auffinden von Daten. In der Regel verwenden Trustcenter dieses Protokoll zum speichern der Zertifikatsinformationen. Über dass LDAP-Protokoll können weltweit die öffentlichen Zertifikate (Public Keys, PKCS#7) bei den einzelnen Trustcentern (CAs) abgerufen werden, die zum Verschlüsseln von Daten dienen. (siehe Asymmetrische Verschlüsselung, Trustcenter)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
MD5
ist ein Hash-Verfahren (siehe Hash Wert)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Öffentlicher Schlüssel (PublicKey)
Der öffentliche Schlüssel (Public Key, PKCS#7) müssen sie weitergegeben (Publik Key Exchange) oder in einer Datenbank (PKI - Public Key Infrastructure) hinterlegen. Daten, die mit einem öffentlichen Schlüssel verschlüsselt wurden, können nur mit dem entsprechenden privaten Schlüssel (Public Key) wieder entschlüsselt werden. (siehe auch asymmetrische Verschlüsselung, PKI, Privater Schlüssel)

One Time Pad
Bei dieser Art von Verschlüsselung werden die Daten durch eine einfach Addition (modulo 26) mit einem Schlüssel der gleichen Länge verknüpft. Der Schlüssel wird durch einen Zufallsgenerator erstellt und nur einmalig verwendet. Dadurch gilt dieses Verfahren als absolut sicher. Das Problem besteht nur darin, für große Mengen an Daten eine wirklich zufällige Quelle für den Schlüssel zu finden. Außerdem ist der Schlüssel genau so groß wie der zu verschlüsselnde Text, wodurch sich die übertragende Datenmenge verdoppelt. Darum wird dieses Verfahren in der Regel nur für kleine Datenmengen verwendet.
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Peter Gutman Methode
Bei der Peter Gutman Methode handelt es sich um eine sehr sichere Methode zum Löschen von Daten auf magnetischen Datenträgern. Dabei werden die Daten insgesamt 35mal in folgender Reihenfolge 4x Random, 0x55, 0xAA, 0x92, 0x49, 0x24, 0x00, 0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88, 0x99, 0xAA, 0xBB, 0xAA, 0xCC, 0xDD, 0xEE, 0xFF0x92, 0x49, 0x24, 4x Random überschrieben. (siehe auch DOD - Methode)
Ausführliche Informationen: http://www.cs.auckland.ac.nz/~pgut001/pubs/secure_del.html

PGP
(Pretty Good Privacy) bedeutet übersetzt etwa "recht gute Privatsphäre" und wurde von Phil Zimmermann entwickelt. PGP in den verschiedenen Versionen ist recht weit verbreitet und implementiert das RSA-Verfahren in eine relativ bedienerfreundliche Oberfläche. (siehe auch asymmetrische Verschlüsselung, RSA)

PKCS#7 & PKCS#12
PKCS (Public Key Crypto Standards) ist ein Set von verschiedenen Standards für die asymmetrische Verschlüsselung (PublicKey Cryptography) nach X.509, die von Appel, DEc, Lotus, Microsoft, MIT, RSA und SUN entwickelt wurden. Sie umfassen spezifische und unabhängige Implementierungsstandards, Spezifikationen und anderes, welche durch RSA Data Security Inc. überwacht wird. Im speziellen beschreibt PKCS#7 den Standard für den öffentlichen Schlüssel (PublicKey) und PKCS#12 den Standard für das Zertifikat (privater Schlüssel, Private Key, Dateiendungen z. B. *.pfx, *.p12). (siehe auch Hash Wert, RSA, X.509)

PKI
(Public Key Infrastructure) ist eine Hierarchie von Zertifizierungs-Autoritäten. Es dient also der Verteilung und Verwaltung von öffentlichen Schlüsseln für die asymmetrischen Verschlüsselung. (siehe auch asymmetrische Verschlüsselung)

Private Key
(siehe Privaten Schlüssel)

Privater Schlüssel (Private Key)
ist der geheime Schlüssel (Private Key, PKCS#12) der unter keinen Umständen weitergegeben werden darf und mit dem Daten signieren (Unterschrift) und entschlüsselt werden. Er ist bei Ihnen im der Systemzertifikatsdatenbank eingetragen und besitzt als Datei die Endung *.p12 oder *.pfx. (siehe auch asymmetrische Verschlüsselung, RSA, PKCS)

Prozessorchipkarten
(Smartcards) enthalten kompletten Rechner: Prozessor, ROM (EEPROM, EPROM) und RAM. Neben festverdrahten sind hier auch frei programmierbare Sicherungsfunktionen möglich. Insbesondere können Challenge - Response - Protokolle und Kryptoverfahren auf der Karte implementiert werden. Bei ihrer Geldkarte oder Handykarte handelt es sich zum Beispiel um eine Prozessorchipkarte. Die Smartcards sind schon weitaus komplizierter als die Speicherchipkarten, weil sie im Prinzip alle Komponenten eines Computers besitzen (siehe oben). Diese Karten enthalten meist auch einen Cryptochip, mit dem Verschlüsselungen und Authentifikationen durchgeführt werden können. Für diese Operationen muss der geheime Schlüssel die Chipkarte nicht verlassen, was diesen damit sehr sicher macht.

PublicKey
(siehe öffentlicher Schlüssel)

Public Key Verfahren
ist die englische Bezeichnung für die asymmetrische Verschlüsselung mit einen öffentlichen Schlüssel (Public Key) und einem privaten Schlüssel (Privat Key) (siehe auch asymmetrische Verschlüsselung, öffentlicher Schlüssel, privater Schlüssel)
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
RC4
Bei RC4 von RSA Data Security Inc. (www.rsasecurity.com) wird in Abhängigkeit vom Passwort mit einem Pseudo-Zufallsgenerator eine zufällige Bytefolge in der Länge der zu verschlüsselnden Daten erzeugt. Der Geheimtext ergibt sich aus der einfachen XOR-Verknüpfung mit dem expandierten Schlüssel, ähnlich wie beim One Time Pad. Zur Entschlüsselung wird dieses Verfahren einfach erneut angewendet. Das Verfahren ist erstaunlich einfach, schnell und sehr leicht zu programmieren. Nach Aussage von RSA Data Security Inc. lässt sich dieses Verfahren nicht mit der linearer oder differentieller Kryptoanalyse knacken. (siehe auch One Time Pad)

RSA
ist benannt nach den Entwicklern Ronald Rivest, Adi Shamir und Leonard Adleman. Das RSA - Verfahren ist eigentlich das bekannteste Verfahren und auch das Flagschiff unter den asymmetrischen Verfahren. Ab einer Schlüssellänge von 2048bit kann es als sicher eingestuft werden. Das RSA - Verfahren wird i. d. R. zur Verschlüsselung und Übertragung von symmetrischen SessionKeys verwendet, weil der mathematische Aufwand für eine Onlineverschlüsselung einfach zu groß ist.
(siehe auch asymmetrische Verschlüsselung)

1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
SectretKeyVerfahren
ist die englisch Bezeichnung für die symmetrische Verschlüsselung mit einem geheimen Schlüssel (SecretKey) (siehe symmetrische Verschlüsselung)

 Secure Message Envelope (SME)
(siehe Digital Envelope)

Selbstsignierte Zertifikate
sind normalerweise als nicht vertrauenswürdig einzustufen, da keine Zertifizierungsstelle für die Richtigkeit der angegebenen Daten bürgt. Damit können keine offiziellen Geschäfte abgewickelt werden. Für die private Verwendung ist es aber vollkommen ausreichen, z. B. zur Verschlüsselung mit der Software von abylonsoft.

SHS/SHA
(Secure Hash Algorithm) ist ein sicheres Hashverfahren (siehe Hash Wert)

Signatur
Die Signatur entspricht einer digitalen Unterschrift für elektronische Daten. Seid dem Signaturgesetz gelten Signaturen als Rechtsgültig und werden damit einer handschriftlichen Unterschrift gleichgestellt.
Für die Digitale Signatur ist ein Zertifikat mit einem öffentlichen (Public Key) und einem privaten (Private Key) notwendig. Zum Signieren wird erst der Hashwert (Quersumme, Fingerabdruck) der Datei gebildet und dieser mit dem Privaten Schlüssel des Unterschreibenden signiert (eine spezielle Art der Verschlüsselung). Es wird nur der Hashwert signiert, damit Rechenzeit und Speicherplatz gespart wird. Dabei muss der mathematische Vorgang des hashens eine Einwegfunktion sein. An die Daten werden die Signatur und der öffentliche Schlüssel des Unterschreibenden angehangen. Die Überprüfung der Signatur nennt man Verifikation. (siehe auch Hashwert, Verifikation, Zertifikate)

Smartcards
ist die englische Bezeichnung für eine Prozessorchipkarten (siehe Prozessorchipkarten)

SME - Datei
(siehe Digital Envelope)

S/MIME-Verfahren
(Secure / Multiporpose Internet Mail Extension); erweitert das MIME-Format für das Versenden von Binärdateien via E-Mail um Verschlüsselung und digitale Signatur (für RSA).

Speicherchipkarten
enthalten nur elektronischen Speicher (EPROM, EEPROM oder RAM) auf den direkt zugegriffen werden kann. Eine Krankenversichertenkarte ist zum Beispiel so eine einfache Speicherchipkarte. Auf diese Karte können nur eine bestimmte Menge an Daten abgelegt und
wieder gelesen werden. Dieser Kartentyp ist in seinem Aufbau recht einfach und auch nicht besonders geschützt.

Sperrliste
Diese Listen werden von den Trustcentern (CAs) angeboten und beinhalten alle ungültigen und gesperrten Zertifikate. (siehe auch Trustcenter, Zertifikate)

Steganograpphie
ist das Verstecken von Daten in Bilder, Videos, Texten oder anderen Daten. Meistens Werden die zu versteckenden Daten zuvor verschlüsselt. Die Steganographie wird meistens zum verdeckten Übermitteln benutzt. Ein anderes Anwendungsgebiet ist, in Bilder zum Beispiel eine kleine Botschaft einzuschleusen um später einmal beweisen zu können, dass das Bild von ihm stammt.

SYMM-System
Die Software von abylonsoft unterscheidet ab der Version 5.3 bei der Verschlüsselung von Daten zwischen dem HYBRID- und SYMM-System. Beim SYMM-System werden die Daten direkt mit Hilfe eines Passwortes verschlüsselt. Alternativ unterstützt die Software von abylonsoft die symmetrischen Verschlüsselung mit einer EC-Karte (mit Chip) oder einer Krankenversichertenkarte. Als Verschlüsselungsalgorithmen werden beispielsweise AES oder Blowfish eingesetzt. (siehe auch HYBRID-System, symmetrisch Verschlüsselung, Blowfish, AES)

Symmetrische Verschlüsselung

Bei der symmetrischen Verschlüsselung wir eine Datei nach bestimmten Verschlüsselungsalgorithmen (siehe. AES, Blowfish, DES und IDEA) verschlüsselt. Die Sicherheit des verschlüsselten Datei hängt von dem Verschlüsselungsverfahren, dem Passwort und der Schlüssellänge ab. Durch die Verwendung von sehr großen Schlüssellängen (> 128 Bit) kann die Verschlüsselung sehr sicher sein.
Der Nachteil der symmetrischen Verschlüsselung besteht darin, das beim Datenaustausch über unsichere Kanäle (Internet) ebenfalls das Passwort übermittelt werden muss. Diese Passwortübergabe ist nur durch eine persönliche Übergabe absolut sicher.
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
TripelDES
ist ein symmetrisches Verschlüsselungsverfahren, bei dem drei mal hintereinander das DES - Verfahren angewendet wird. (siehe DES)

Trustcenter
Trustcenter (im englischen Certification Authority (CA)) bieten Zertifikate (Schlüsselpaar aus Public Key und Private Key) für den rechtsverbindlichen und vertraulichen Datenaustausch. In Deutschland werden sie von der Regulierungsbehörde für Post und Telekommunikation überprüfte und zertifiziert (z. B. TC Trustcenter oder D-Trust). Diese Trustcenter müssen besonders hohen Sicherheitsanforderungen genügen. Sie garantieren, dass die von Ihnen ausgestellten und geprüften Zertifikate (Schlüsselpaar zum Signieren und Verschlüsseln) nach dem deutschen Signaturgesetz authentisch sind. Dieses Zertifikat kann nur die Person verwenden, die sich beim Trustcenter ausgewiesen hat.
Daneben gibt es noch freie, nicht zertifizierte Trustcenter, die ebenfalls Zertifikate ausstellen aber keinerlei Garantie übernehmen (z. B. web.de oder Christian Barmala's Free CA).

1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Verifikation
Als Verifikation wird die Überprüfung einer Signatur bezeichnet. Die Signatur gibt dabei Auskunft, von wem die Daten signiert (unterschrieben) wurden und ob sie authentisch (unverändert) sind.
Technisch wird dabei die Signatur mit dem beigelegten, öffentlichen Schlüssel (Public Key) des Unterschreibenden nach einem speziellen Verfahren dechiffriert (entschlüsselt). Als Ergebnis erhält man einen Hashwert. Parallel wird der Hashwert der übertragenden Daten gebildet und mit dem beigelegten Hashwert verglichen. Stimmen beide Werte überein, so kann der Empfänger sicher sein, dass die Daten nicht verändert wurden und von dem entsprechenden Absender stammen. (siehe auch Signatur, Zertifikate)

Verschlüsseln
Als verschlüsseln bzw. kodieren, bezeichnet man den Prozess, bei dem Daten (z.B. Texte, Bilder usw.) so verändert werden, dass ein nicht autorisierter Betrachter die Daten nicht lesen oder aus ihnen den Inhalt erschließen kann. Man unterscheidet dabei zwischen der symmetrischen und der asymmetrischen Verschlüsselung. (siehe auch Asymmetrische Verschlüsselung, Symmetrische Verschlüsselung).

1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
X.509 / V3 - Zertifikate
bestehen aus einem ASN.1 kodierten Format mit Version, Seriennummer, Signatur, Name, Gültigkeit, Subjekt, PublicKeyInfo, Parameter und Zertifikatserweiterungen und wird von der abylonsoft Software unterstützt. S/MIME, PGP, PEM und MailTrusT verwenden dieses Zertifikat. (siehe auch Zertifikate, S/MIME, PGP, ASN.1)

XOR-Verknüpfung
Bei der Exklusice-Oder-Verknüpfung (XOR) verwendet man folgende Regeln zur Verknüpfung von zwei Bits. Wenn beide Bits gleich sind (1/1 oder 0/0) wird das Ergebnis Null und bei ungleichen Bits (1/0 oder 0/1) ergibt sich eine Eins. Im Gegensatz dazu wird bei der einfachen Oder-Verknüpfung (OR) aus zwei Einser Bits (1/1) wieder eine Eins.
1 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Zero-Knowledge Verfahren
eignen sich dazu, einen Kommunikationspartner davon zu überzeugen, dass man ein Geheimnis G kennt, ohne irgendetwas über G mitzuteilen. Dazu bedient man sich zweier Mengen von geheimen und öffentlichen Schlüsseln. Mit einem mehrfach wiederholten Challenge-Response-Protokoll wird schließlich die Authentifikation durchgeführt.

Zertifikate
werden in der Regel mit der Dateiendung PFX oder P12 abgespeichert und beinhalten eine Reihe von Daten über den Aussteller und Besitzer. Mit dem öffentlichen (Public Key, PKCS#7) und privaten Schlüssel (Privat Key, PKCS#12) können Daten authentisch, digital unterzeichnet oder ver- und entschlüsselt werden. Für die Glaubwürdig der im Zertifikat angegebenen Daten garantiert normalerweise der Aussteller (Trustcenter, CA). Um die Glaubwürdigkeit zu erhöhen, kann ein Zertifikat von mehreren CAs signiert werden.
Jedoch sind auch selbstsignierte Zertifikate nützlich, beispielsweise zum Signieren in Freundeskreis oder einfach für die Verschlüsselung der eigenen Daten. (siehe auch Selbstsignierte Zertifikate, X.509-Zertifikate, Trustcenter (CA), Signatur, asymmetrische Verschlüsselung)


abylonsoft: abylon LDAP

Nur abylon ENTERPRISE Im Funktionsumfang dieser Version, abylon KEYSAFE Im Funktionsumfang dieser Version, abylon CRYPTDRIVE Im Funktionsumfang dieser Version , abylon SHAREDDRIVE Im Funktionsumfang dieser Version und abylon CRYPTMAIL Im Funktionsumfang dieser Version
Beschreibung abylon LDAP
Mit dieser Oberfläche können Sie auf verschiedenen LDAP-Servern von Zertifizierungsstellen (CA) zugreifen und nach öffentlichen Schlüsseln (Public Keys) von Personen suchen. Dazu ist eine Internetverbindung notwendig.

Funktionsumfang:

  • Zugriff auf LDAP-Verzeichnisserver
  • Freie Suche und Suche nach Name oder Email-Adresse möglich
  • Anonyme oder authentifizierte Anmeldung
  • Sperrlistenprüfung

Übersicht abylon LDAP

1. | Zertifikatsliste | In dieser Liste werden alle Zertifikate angezeigt, die Ihrem Suchkriterium entsprochen haben.
2. | LDAP-Server | Adresse (URL) des LDAP-Servers, wobei einige Server (z. B. Trustcenter und D-Trust) standardmäßig vorgegeben sind.
3. | Port | Portnummer des LDAP-Servers, über den der Zugriff erfolgt. Diese entsprechenden Ports sind für die vorgegebenen LDAP-Server schon eingetragen. Bei den meisten LDAP-Servern wird der Port 389 verwendet.
4. | Suchbasis | Jeder LDAP-Server benötigt ein speziellen Syntax um nach Zertifikaten zu suchen. Diese Suchbasis ist für die vorgegebenen LDAP-Server schon eingetragen. Bei anderen LDAP-Servern fragen Sie bitte Ihren Administrator oder den entsprechenden LDAP-Server Betreiber.
5. | Suchoptionen | Es kann gewählt werden, ob nach 'Namen' oder 'Emailadressen' gesucht wird. Auch eine freie Suche ist möglich, wofür jedoch der genaue Suchsyntax bekannt sein muss. Eine Freie Suche kann zum Beispiel die Form CN=Name haben.
6. | Suchbegriff | Zeichenfolge, nach der auf dem LDAP-Server gesucht werden soll. Meist sucht man nach Vor- und Zunamen. WildCards (Platzhalter) sind vorne und am Ende erlaubt und müssen als Sternchen '*' angegeben werden.
7. | Authentifikation erforderlich | Sollten Sie sich zur Suchabfrage mit einem Passwort ausweisen müssen, so wird bei Aktivierung dieses Feldes ein Passwortdialog angezeigt.
8. | Zertifikat(e) in Sperrliste prüfen | Bei Aktivierung dieses Punktes werden alle Zertifikate überprüft, ob sie eventuell auf einer Sperrliste stehen.
9. | History löschen | Durch Klicken dieses Feldes werden alle eingegebenen LDAP-Server gelöscht und durch die Standardwerte ersetzt.
10. | Suchen | Durch Klicken dieses Button wird Ihre Anfrage an den LDAP-Server gestartet. Dies kann teilweise etwas länger dauern und setzt eine Internetverbindung voraus.
11. | Übernehmen | Alle in Zertifikatsliste 1 selektierten Einträge werden in Ihre Zertifikatsdatenbank mit der Bezeichnung LDAP übernommen.
12. | Statusleiste | Anzeige einer kurzen Info zu den einzelnen Zertifikaten.

Siehe auch
>> Zugriff auf einen LDAP-Servers